Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I use a MacBook Pro with a Cinema Display and every time when I wake the MacBook Pro, the cinema display wakes first and the MacBook Pro display seems to stay in a sleep mode until I press the Detect Displays button in Displays Preferences. The most annoying part is that I need to rearrange all open apps' widows every time I wake my Mac.

Does anybody have any idea how to fix this problem?

share|improve this question
    
What MBP and what Cinema Display models are you using? I have trouble with the 15" MBP Retina Display and the 21" Cinema Display (but not with the 30"). With that combination, I've heard using the HDMI port instead of the Thunderbolt port resolves the issues although I haven't been able to test that. –  Dominique Jan 16 '13 at 0:39
    
Did this get resolved? It may have been related to the SMC chip on the Mac, which controls many power-related hardware components: support.apple.com/kb/ht3964 –  bispymusic Mar 3 '13 at 0:42
    
@bispymusic It's not been solved yet. I've heard this problem is solved in ML but I still have Lion on the laptop. Thanks for the link but it's corporate MBP and I am quite reluctant to remove the battery on my own ... –  Dmytro Mar 3 '13 at 10:26
    
Are you still having issues with this? I've tidied up the title to see if fresh eyes can help. –  bmike Apr 24 '13 at 14:19
    
@bmike Yes I still have this problem and I think the solution would be to upgrade to ML. –  Dmytro Apr 24 '13 at 16:22
add comment

3 Answers

You ask for a fix where one of your screens does not wake up. I have a fix for a similar problem as my second screen on my MacMini (server 2011) does not wake up. It's not pritty but it is a fix.

I noticed that the screen wakes up after you change the screens refresh rates, so I use cscreen to do this. After my computer wakes up I run the following script. There are multiple solutions to run scripts just after waking up your machine (like Scenario and Power Manager).

#!/bin/bash
# b.nelissen

# cscreen: http://www.pyehouse.com/cscreen/

# wake up screen when one of these two displays are found
if [ "$(cscreen -l | grep '2b1052d0\|3c0c07c2')" != "" ]; then
    echo "Display found"
    # Dell screen does not wake up, switch back and forth to wake her up
    cscreen -i 2b1052d0 -d 32 -x 1280 -y 1024 -r 60 # small dell screen
    cscreen -i 2b1052d0 -d 32 -x 1280 -y 1024 -r 75 # small dell screen
    cscreen -i 3c0c07c2 -d 32 -x 1920 -y 1200 # big compaq screen
fi

# exit

What it does in short

  • Check if the screen is connected (I switch screens between home and work)
  • Refresh rate for displayID '2b1052d0' first to 60 than to 75 (to wake up the screen)
  • Set the second screen to her normal settings.
share|improve this answer
add comment

Try unchecking the "Automatic adjust brightness" in the System Preferences Display control panel.

share|improve this answer
add comment

Are you using a USB keyboard/mouse? MacBook Pros with ML have a feature that if you use external peripherals and wake your computer with them, it will act as a desktop computer without using the laptop display. If this is the case, try without the keyboard/mouse connected, or try waking with the built in keyboard/trackpad/power button.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.