Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have ActiveSync enabled on my Exchange 2007 server, and it works just fine with all the other iPhones (4S and below) in the office. However, I have two users who have just gotten iPhone 5s, and neither of them can connect to the Exchange server.

ActiveSync is enabled on their accounts (I checked), and I've tried clearing the ActiveSyncAllowedDeviceIDs property on their accounts so any device should be able to connect, but no luck so far. I've tried rebooting the devices (universal patch, huh?) but that didn't work either. Oddly, the devices seem to authenticate just fine, the account gets added to Mail without issue.

I don't think it's an iOS 6 issue because I've upgraded my iPhone 4 to iOS 6 and I can still get my mail. Has anyone else encountered this problem?

Follow up: Apple support couldn't provide a fix. They suggested importing the Exchange server's SSL cert, which I did to no avail. One user's account works on his iPhone 4S but not his iPhone 5 (yes, he is using two phones at once). The other two users don't have other devices using ActiveSync, and they have no other mobile device partnerships (I cleared the old ones when they upgraded their phones).

share|improve this question
I have 50 iphone 5s and several Ipads with the same problem. No answers so far. The Ipads can't connect since the update from ios 5 to 6. – user30854 Sep 27 '12 at 13:04

I had exactly the same problem and it turned out that i had used 10 devices do remotely get my corporate mail and thats the limit in exchange. Had to open the outlook web access portal and delete the old devices and it worked straight after that.

share|improve this answer
Unfortunately that doesn't work for me - neither of them have hit 10 devices. I even removed all the existing devices attached to one of the accounts and set activesyncalloweddeviceids to $null but it still couldn't work. His old iPhone 4S on iOS 6 worked though. – Seyren Oct 6 '12 at 8:41

protected by Community Oct 5 '12 at 19:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.