Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I start Braid on my Retina Macbook Pro, the game will sometimes start normally, and I can play it, but other times only the bottom left corner of the game is visible, and the graphics look really ugly. The same happens with Trine 2.

I don't know when it works or when it doesn't, just that it seems somewhat random to me. Could it have something to do with the graphics cards? Right now my battery is at 100%, and I'm connected to the charger, so I think the discrete card is the one powering the game. Could this be the problem? How do I tell?

Also, on each game's launcher, I select the "2880x1800" resolution.

Here's Braid looking all messed up:

Less-than-impressive retina graphics

share|improve this question
add comment

4 Answers 4

up vote 4 down vote accepted

Thanks @eternus for answering, but my issue was that for some reason, my computer doesn't always switch to the discrete card once I open a game. Restarting usually fixes the problem, but a more thorough way to solve it is to get this app called gfxCardStatus, which allows you to specify which card you'd like to use. You choose the "Discrete only" option before running a game, and it should work fine. Here's what it looks like running in your task bar:

enter image description here

share|improve this answer
    
This actually fixes the problem. Thank you! –  nuc Aug 2 '13 at 22:26
    
@nuc Glad I could help! –  Hassan Aug 4 '13 at 7:46
add comment

You can fix this with no extra apps by disabling "Automatic Graphics Switching" under the Energy Saver section of System Preferences.

share|improve this answer
add comment

It sounds like the game isn't optimized for Retina Display, though it's odd that it sometimes works and sometimes not. Try setting the .app to open in Low Resolution. You can do this by right-clicking the .app file > Get Info and check "Low Resolution" option under the General section.

share|improve this answer
    
+1 thanks for your answer, but I figured out the problem (see below). –  Hassan Sep 26 '12 at 18:53
    
This didn't work for me since the Low Resolution option was already checked and greyed out. Hassan's gfxCardStatus was the way to go. –  Cthutu Jan 26 '13 at 15:56
add comment

If I could up vote @cidermonkey's answer, I would. You don't need an app (free or otherwise) to manually toggle the discreet graphics.

share|improve this answer
    
Consider posting a comment instead of an answer if you are not directly trying to answer what the question is about. –  Alex Mar 14 '13 at 7:52
1  
I don't have enough reputation for that either. If/when I do, I'll circle back around and move this to a comment because you're right, it isn't an answer to the question. –  ele Mar 14 '13 at 14:13
    
@cidermonkey's is not a bad answer (and I did upvote him/her), but I think disabling automatic graphics switching will kill your battery life. It's nice having the discrete card switch off when you're not using it. –  Hassan Mar 14 '13 at 17:06
    
Oh, for sure. I just turn automatic switching back on once I'm done playing. –  ele Mar 14 '13 at 18:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.