Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How do I stop Mountain Lion from asking me to put in my password everytime I want to move/change folders/files etc?

An example is "Finder want to make changes. Please enter your password to allow this"

share|improve this question
if it's doing this for every time you move any file, you should try Repairing Disk Permissions in Disk Utility – Ethan Lee Sep 22 '12 at 3:41
  1. Open Applications > Utilities > Disk Utility.
  2. Select your hard drive in the left column. Most likely it will be named “Macintosh HD.”
  3. Click on “Repair Disk Permissions.”
  4. Close Disk Utility. Check if the problem is still there.
  5. If it is still not resolved, restart and hold down the Command and R keys. You will boot into the Repair Utilities screen. On top, in the Menu Bar click the Utilities item then select Terminal.
  6. In the Terminal window, type reset password and hit Return. The Password reset utility launches, but you’re not going to reset the password.
  7. Instead, click on the icon for your Mac’s hard drive at the top. From the drop-down below it, select the user account where you are having issues. At the bottom of the window, you’ll see a button labeled ‘Reset Home Directory Permissions and ACLs’. Click the Reset button there.


share|improve this answer
I did both of these things and I still have this problem. I'm on Mavericks. Any ideas? – WendiKidd Apr 19 '14 at 1:25

Just had the same Problem. I went to System Preferences >> Users & Groups, clicked the unlock button then right clicked on my User and set my group to Admin.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.