Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm trying to mount an Ext3 external USB hard drive in OS X 10.7.4. I installed OSXFUSE (with macfuse compability layer), which worked fine. After that I tried to install EXT2FS but the install processs always aborted.

Any ideas?

share|improve this question
    
If your question is about how to mount an ExtFS file system, check this possible duplicate. –  kopischke Oct 29 '12 at 9:04
add comment

1 Answer

Have a look at this open source project: fuse-ext2. This link:

http://blog.applegrew.com/2011/12/access-ext3ext2-file-system-on-mac-osx-lion-10-7/

explains how to configure fuse-ext2 and OSXFuse on OS X 10.7 "Lion" to get access to ext3-formatted drives.

(The project is tagged beta and inactive since 1 year (last commit on Aug 15 2011), but according to the link above it is compatible with "Lion". You only will get read-only access, read/write is not ready for prime time...)

Another possibility, as linked by kopischke in his comment, is a commercial solution called Paragon’s ExtFS driver. It's not clear from the feature list whether ExtFS driver works on OS X 10.7 "Lion", so if you decide to go this way be sure to find out before purchasing it.

Other projects, like Ext2 for Mac OS X or ext2 filesystem in user space are either tagged inactive or alpha.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.