Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I access my Synology NAS via AFP and can open/edit all of my files directly on it. But when I copy a file to my desktop I can't open it. Finder tells me I don't have appropriate permissions.

When I look at the permissions (CMD + I) on …

… my NAS:

  • (unknown): read & write
  • everyone: no permissions

… my desktop:

  • staff: read & write
  • everyone: no permissions

ls -l will print (for both paces): ----rwx--- 1 suntrop staff 35354 4 Jul 10:32 File.docx

Is this a problem on the Mac or Synology or my settings?

share|improve this question
1  
The permissions should ideally be 755, i.e., rwxr-xr-x at both places. – duci9y Sep 20 '12 at 9:14
    
Ok, thanks. And what causes the problem or how to avoid it? :-) – suntrop Sep 20 '12 at 11:03
    
I don’t know what caused the problem or how to avoid it, but you can probably fix it by running sudo chmod -R 755 /path/to/drive in the Terminal. That’s why I didn’t put this as an answer. – duci9y Sep 20 '12 at 11:06
    
That's not only this particular file. Almost all files have this problem. anyway, I'll check some other resources and try to fix it. Thanks. – suntrop Sep 20 '12 at 16:52
    
No, I did not say path/to/file, I said path/to/drive. This will fix ALL files on the drive. – duci9y Sep 20 '12 at 17:04

Sounds like a permission problem. I had a similar issue. Files created by one user in two groups (administrator & user) on NAS were not being able to read by users only in the user group. I tried reseting ownership/permissions using File Station from DiskStation and did nothing. I figured something was wrong with root folder permissions on shared folder - and yes, they were owned by root and 777 chmod.

I've managed to fix this by:

  1. On the Synology - control panel - win/mac/nfs - goto Mac File Serivce (AFP) and turn off Apply default UNIX permissions (Mac file services enabled) - root of your problem
  2. log on to NAS via ssh, go to most root shared folder and do

    chown -R nobody:users shared_folder/
    chmod -R 755 shared_folder/
    

used info from here, here and here.

share|improve this answer
    
thanks @klanomath much nicer. :) – seven Apr 13 at 14:24

Do not connect via AFP: use SMB.

share|improve this answer
5  
Why should they connect via SMB instead of AFP? While this might be exactly right, some more explanation would be nice. – CajunLuke Oct 8 '12 at 18:29
    
Although SMB will work it doesn't support some of the OS X features I like. I submitted a bug report to Apple and – I hope – they fix it :-) – suntrop Oct 9 '12 at 20:44
    
Synology had to reverse engineer AFP, whereas SMB is open source. That's why SMB is safer to use, especially with newer OS X versions – willWorkForCookies Mar 17 '15 at 12:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.