Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I can set up my work Exchange account just fine on my iPhone, but I can't get it to work on Mail.app under Snow Leopard.

I have read some forums and understand that mobile devices use ActiveSync in order to access Exchange mail and I thought Snow Leopard introduced this feature to Mail, but I can't seem to get it working.

I have tried just about every combination of settings I can think of.

My iPhone asks for a domain, but I can't find a similar setting in Mail. I have tried entering my username as domain/username to no avail.

Has anyone had experience/similar problems with this?

share|improve this question
    
I've never been able to get Mail.app to use the Exchange account that Google provides for mobile device use. Any chance they're using Google? –  Kyle Cronin Jan 17 '11 at 18:50
add comment

6 Answers

Try domain\username. I've never seen a forward slash work to indicate a domain. Then again, I've never tried. Do you get any error messages?

share|improve this answer
    
Why are you suggesting that they try to use a forward slash if you don't think it'll work? –  CajunLuke Aug 23 '12 at 4:31
    
@CajunLuke Where did I suggest a forward slash? I suggested a backslash. My reason for suggesting it was that "I've never seen a forward slash work". –  Harv Aug 23 '12 at 21:01
    
Nevermind, it appears I've gotten forward and backslash mixed up. (I always thought the regular slash (/) was forward slash and the DOS/escape slash (\) was backslash.) –  CajunLuke Aug 23 '12 at 21:09
1  
@CajunLuke That's correct. My shortcut for remembering is, "if it could be affected by gravity, which way would it fall?" Forward slashes "fall" forwards, and backslashes fall backwards. –  Harv Aug 24 '12 at 22:53
add comment

AFAIK: Snow Leopard supports Exchange via Web Services (new in Exchange 2007). All mobile devices use ActiveSync (which is basically XML over long lived HTTPS sessions). Using IMAP to check email on Exchange is fine (if enabled on server) but you lose calendar and contacts sync.

share|improve this answer
add comment

I'd been struggling with the same issue for over a year. Finally I installed DavMail Gateway which is free.

It provides support for Exchange 2003 ( using OWA ). Using it you can even get support for LDAP directory services & even events in iCal!!

See page for details. Step-by-step instructions on:

Setting up DavMail on OS X

IMAP Mail setup

share|improve this answer
add comment

I've been having this problem with Exchange Server 2003 and Mail under Snow Leopard, and it's because the IMAP process on the server periodically dies. This affects the Mail app on the computer and not the iPhone because, as another answer here mentions, the iPhone uses ActiveSync, while the Mail app on the computer relies on IMAP if it's not Exchange 2007 or newer. Someone needs to log into the server and restart it.

One possible fix is here.

share|improve this answer
add comment

Most likely because your corporate exchange server is running Microsoft Exchange Server 2003. Snow Leopard now only connects to Exchange 2007 (See http://www.apple.com/macosx/exchange/) whereas Leopard used to connect to Exchange 2003 using the OWA mechanism.

iPhone supports both Exchange 2003, 2007 and 2010 it seems (See iPhone User Guide , page 2);

share|improve this answer
1  
It could also be an early version of Exchange 2007, it needs at least Service Pack 1, update rollup 4. –  Lizzan Sep 16 '11 at 5:59
add comment

Have you tried everything listed in this Apple doc?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.