Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently upgraded to iOS 6 on my iPhone 4, and since then I am unable to connect to any WiFi. When I try to connect to WiFi, it briefly connects, then brings up a dialog to a bogus Apple website. What is going on?

I don't have a proxy server setup, or anything like that.

So far I have:

  • Rebooted access points
  • Restarted Phone
  • "Reset Network Settings" on my iPhone

Here is what is brought up:

enter image description here

That just magically appears when I try to connect to WiFi from Settings.


Seems like many other people are being affected by this.

I am having same problem on iPhone 4s. It connects to router then tries to bring me to page. Then kicks me off network.

share|improve this question

closed as too localized by Daniel Sep 20 '12 at 1:00

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Are you connecting to wifi networks that use a captive portal? (ie, you need to enter a username and password into a browser window before internet will work). – Chris Herbert Sep 19 '12 at 23:44
@ChrisHerbert No - they have WPA2, that's it. I'm using these access points from other devices just fine. – vcsjones Sep 19 '12 at 23:47
This was a transient problem where the probe page on Apple .com disappeared. Should probably close this – Kevin Sep 20 '12 at 0:00

See this thread at

Select the triangle at the right of wi-fi router you're trying to connect to. Scroll to the bottom and change the HTTP Proxy from OFF to AUTO.

share|improve this answer
This fixed it for me. After connecting, I was able to switch it back to "off" and can still connect fine. – ughoavgfhw Sep 20 '12 at 0:23

I had the same problem with iOS 6 and I just figured it out. You have to reset your all of your network settings. This means you will have to locate and type in the passwords to all of your favorite networks. Nonetheless it has worked so far.

Go to: Settings - General - Reset (at the bottom) - then click "Reset Network Settings".

Then connect to your network, type in the password, and then you should be back to normal.

share|improve this answer

FWIW, the way I got it working was to forget the network, access the network again (enter password), then, in the network details, tap the slider for Auto-Join or that network.

(As I check the settings now, that slider is not there. Maybe because I'm currently on the network.)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.