Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Keyboard: Apple Wireless Keyboard (model number MC184LL/B)

System: Macbook Pro Early 2011 running OS X 10.8

The keyboard gets detected and when I try to pair it, the system asks to enter some numbers through the keyboard.

However when I press the key (on the wireless keyboard) nothing happens, the only key that seems to work (i.e. to move to the next key in the code) is 0. I can also press enter to confirm but it always fails (since the only code I can enter is 0000...0).

I've also tried pairing from the bluetooth preference and changing the passcode option. However this won't work either.

Any ideas? The keyboard was paired with another MacBook Pro (I don't have access to it anymore). Is there any method to 'reset' the keyboard to factory settings?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

If only one number key is working, it sounds like a hardware issue. My brother had a wireless keyboard that flaked out and only certain keys functioned (although in his case it was from a liquid spill).

Do you have any other Bluetooth-capable device to test with? Any iOS device can pair with the keyboard to test it.

share|improve this answer
    
Seems numeric keys from 1 to 9 are dead, got it paired by using '0000' as the code. Every other key is working. Sounds like a hardware issue as you said, any chance that this could be battery related? I've found that my batteries are 1.2v (rechargeable), normal batteries are 1.5v, it's a long shot, but... –  aromero Sep 19 '12 at 23:36
    
Changed batteries, same issue. Tested on pc with windows and also Android mobile phone, same issue. It's a hardware problem, thanks for your help –  aromero Sep 20 '12 at 0:38
    
No problem, if my question solved your issue, please mark it as answered (the checkmark). –  robmathers Sep 20 '12 at 1:11

For posterity, some troubleshooting on this exact same problem...

After reading the question and answer here I was ready to throw the keyboard in the trash, but then thought that if two people have such an odd failure maybe its just a bug that one can work around.

So, after being unable to type anything but 0 and enter and watching the connection attempt fail, I clicked a button on the failure screen that allowed me to then choose an alternate passkey. It was pre-populated with 0000. I played around with connecting again but the enter key would not highlight until I typed eight zeros instead of four. I tried a few times and then noticed for whatever reason the custom setting was back to eight random digits.

I decided to start over, clearing out the list of bluetooth devices. On my next attempt, I typed 00000000 and enter for the passkey and waited for the failure. I then selected the custom passkey setting which was now populated as 0000. I reattempted and was asked to type 0000. I did so, and even though the screen did not show I could hit enter - presumably because it wanted four more digits - I hit enter anyway. And it paired.

I am typing this with that very keyboard. Sounds great. Except this: the keys 1 through 9 still do not work, nor do the symbols on those keys when holding shift. Note I copied/pasted the one and nine digit from elsewhere into this answer :-)

So sad.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.