Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a 2006 Macbook running Snow Leopard. I suddenly noticed that my computer's battery would be at a different level when I woke it up than it was when I closed the lid to put it to sleep. After leaving it on a table next to my bed a few times, I realized that my computer was randomly waking up (evidenced by the Apple logo lighting up) when it was laying on a flat, level surface with nothing on top of it or anything touching it. I tried switching the settings so that I have to click the "sleep" option in the menu rather than relying on it to automatically go to sleep when the lid is closed, but the problem persists. Why won't my Macbook stay asleep?

share|improve this question
1  
Have you tried to disable waking for network access in the energy saver preferences? –  ؘؘؘؘ Sep 20 '12 at 11:07
    
@LauriRanta I've had this problem, too, and not been able to find a solution. This continues happening even with waking for network access disabled. –  Laura Sep 20 '12 at 18:02
1  
Having fought some Genius-stumping sleep issues, I can tell you there's no one cause and one solution for all sleep problems. Assuming it's not expected behavior, watch Console after the next wake and give us a 'wake reason'. Also an OS version. –  duozmo Sep 26 '12 at 4:35
    
do the logs say anything that could be of help? They usually do for sleep related issues. Look for them using Console.app –  Agos Sep 26 '12 at 7:54
    
Same problem. I was forced to give up sleep mode and do a full shutdown when not using it. –  Brian Knoblauch Dec 28 '12 at 14:32

2 Answers 2

One possible cause is that the sensor to detect lid opening can trigger by mistake. If so, you can disable it by going into Terminal.app and typing:

sudo pmset -a lidwake 0

Note that this means the Mac will no longer automatically wake when you open it. Instead you would need a key press or mouse click to wake.

share|improve this answer

What network sharing settings do you have enabled? I found that enabled internet, file or printer sharing will prevent full sleep.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.