Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I started bringing my 2011 MacBook Air to work and hook it up to an external monitor for dual display setup. But when I unplug the display, the desktop wallpapers on the built-in LCD disappears and just show a solid light gray desktop. I have to log out and log back in to get the desktop wallpapers to show again. Is there a way to fix this?

Many apps also still behave as they were on the external monitor. Do I have to use "gather windows" every time I disconnect the external monitor?

share|improve this question
    
I noticed that once I upgraded my late-2011 MBP to 10.8.1 I had to reset all my background preferences as well, external 27" at work - both displays set to randomly display from a custom folder every hour. I forgot exactly what I did but eventually the settings did 'stick'; try setting the preferences the way you want without the external monitor, log out, connect the monitor, log back in, and try setting them again. Rather, rinse, repeat.. –  da4 Sep 12 '12 at 13:18
add comment

3 Answers 3

I also observed the problem after upgrading my MacBook Air (2011) to Mountain Lion. Not only unplugging the external display triggers the gray background, but also connecting to a display.

For the gray background problem, I use a quick-and-dirty fix: restart the Dock. Invoke the following command in the terminal: $ killall Dock

The Dock will be restarted after it is killed, and the wallpaper will appear again.

share|improve this answer
add comment

After some exprimenting, it seems that disconnecting the external display first while the macbook is still open fixes the issue. The problem only arise if I close the lid before unplugging the external display.

share|improve this answer
add comment

Another workaround is to open Terminal and type "killall Dock" at the prompt.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.