Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When opening some folders, the Finder takes a long time (30-60 seconds) to load all the files in it. Specifically, these folders typically contain 10-50 PHP files (which are text files), each about 10 kb.

I also notice that sometimes, after the files are listed, their icons are still loading and the "Kind" column is also still loading. (I've got the "Name", "Date Modified", "Size", and "Kind" columns showing; "Calculate all sizes" is enabled" while "Show icon preview" is disabled.)

In addition, when opening a directory such as this and viewing Activity Monitor, I see that coreservicesd is at 70% CPU and Finder is at 30% CPU. After all the files have loaded, both services are still at these CPU levels for about 60 seconds afterward.

Anyone know how I can fix this? I already did "Repair disk permissions" and "Repair Disk", along with a ton of miscellaneous Onyx tasks, but the problem still remains.

share|improve this question
    
How is the folder displayed (icons, list, column, coverflow)? Is it faster if you switch to another display style (especially column)? –  patrix Sep 12 '12 at 5:43
    
I always use List view. If I switch to Column view, Finder is equally slow at listing files. –  Gary Sep 12 '12 at 6:43
    
If it helps, I'm using TextMate to open PHP files. It's a pretty bloated and old piece of software these days, so perhaps it's somehow slowing down Finder from loading PHP files, perhaps due to QuickLook rendering or something? Also, one very interesting note: if I "Force quit" Finder to make it reload, the file listing will appear immediately. So clearly something is getting bogged down. –  Gary Sep 12 '12 at 7:14

6 Answers 6

up vote 11 down vote accepted

Hallelujah! I figured it out. Okay, so first thing I did was create a new account, as suggested by another answer. The problem did not occur in there, so clearly the problem was limited to my account. I then went into Safe Mode into my account. The problem did not occur as well. So clearly something was loaded in normal mode but not in safe mode that was causing the problem.

While in safe mode, I then cleared the caches (in Terminal, using sudo mv /Library/Caches ~/Temp/ and the same for ~/Library/Caches). Problem solved! I've had other problems as well in Finder so perhaps this will fix this as well. I'm curious as to why using Onyx to clear the User caches didn't clear these as well, but anyway, from what I've read online it seems like getting rid of these two folders is safe. Also, Time Machine never backs up ~/Library/Caches (but it does back up /Library/Caches), so that's reassuring.

In addition, while this post was made in 2003, it still applied to my situation and this was what convinced me to clear my Caches folders.

share|improve this answer
1  
Also, someone figured out that the culprit is often that the finder is waiting on another application for information. Please read about it here. It has solved the problem for many people. –  mareoraft Sep 15 at 18:39

There are many things you can try to fix this:

  • Trashing com.apple.finder.plist, com.apple.systemuiserver.plist and com.apple.loginwindow.plist (they will be recreated when you launch Finder) in ~/Library/Preferences and Force Quit Finder
  • Turning off Calculate All Sizes in Finder
  • Turning off Show View Options in Finder

Another thing you can try, is to create a new (test)account and see if the problem still exists there. Chances are good you'll solve your issue with this.
Worst case scenario, you can move your account to a new one to solve this issue.

share|improve this answer
    
I trashed those three files, and then had them re-created, and I turned off Calculate All Sizes (not sure how I can turn off Show View Options?), but none of these worked. Creating a new account DID work, though, so clearly something is broken in my current account. I'd rather not move my entire account to a new one, though. If possible, I'd rather find the problematic plist file and trash that instead. Any more suggestions as to which one it might be? –  Gary Sep 12 '12 at 17:07
    
You can try to trash all the apple.**.plists... –  Michiel Sep 12 '12 at 17:11
    
Thanks I'll try that. I've got everything backed up to Time Machine so at worst I'll just restore them back if necessary (like I did with the Finder plist because I had a lot of things setup). –  Gary Sep 12 '12 at 18:50

I had the same problem, but none of the fixes above helped. This finally did:

http://blog.hsoi.com/2014/02/25/my-slow-mac-mavericks-coreservicesd-iconservicesagent-and-how-fs_usage-saved-me/

Some issue with an application (in my case Xcode) and icons.

Try this command in Terminal, which reports realtime filesystem activity from the IconServicesAgent:

sudo fs_usage -f pathname -w com.apple.IconServicesAgent | grep open

I got endless output like:

/Applications/Xcode.app/Contents 0.000009 com.apple.IconSe.429515:32:08.066965 open F=4 (R_____)
/Applications/Xcode.app/Contents/Info.plist 0.000010 com.apple.IconSe.429515:32:08.067690 open F=4 (R_____)
/Applications/Xcode.app/Contents/Library/Spotlight 0.000003com.apple.IconSe.429515:32:08.092972 open F=5 (R_____)

I moved Xcode to the trash, and reinstalled from the AppStore. Problem solved, now I have a snappy Finder.

share|improve this answer

I tried @Gary 's answer, it didn't work for me.

My problem was only concerning Shared folders

After a lot of reading and searching, didn't try all solutions, but when i went into the settings-> sharing it was also taking a lot of time to load the settings.

So i disabled everything one by one, afp and smb and windows, and then turned off the sharing service alltogether These folders went fast again, Then i reenabled it, and the problem didn't reoccur.

Hope this helps somebody else.

share|improve this answer

My problem was solved by starting up in Safe Mode (Safe Boot) I opened all the folders that were slow in finder. The first 2 or 3 of them were still slow. Then they started to open really fast. Did nothing more. Restarted my machine & then everything was great. Starting up in Safe Mode To start up into Safe Mode (to Safe Boot), follow these steps.

Be sure your Mac is shut down. Press the power button. Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone. Release the Shift key when you see the gray Apple logo and the progress indicator (looks like a spinning gear). After the logo appears, you should see a progress bar during startup. This indicates that your computer is performing a directory check as part of Safe Mode.

To leave Safe Mode, restart your computer without holding any keys during startup.

Best wishes

share|improve this answer
    
This reminds me of this Apple support document, please do reference your source if you copy text verbatim. –  patrix Nov 19 '13 at 4:33

I had exactly the same issue and this helped. In my case it was an OpenOffice installation causing the problem. I removed OpenOffice and the problem disappeared. I will re-install an updated OO.

Like you I tried all the other tricks in many other threads, to no avail. Many thanks for posting this.d

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.