Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I setup my iPhone 3GS with iOS 4 to sync with my Google account according to the instructions from Google. Somehow, only the default Google calendar with my name is shown in the Calendar app. What should I do to make ALL my Google calendars appear and sync with my iPhone? Thanks!

share|improve this question
    
Same exact thing for me... good question! –  longda Aug 26 '10 at 20:49

8 Answers 8

up vote 17 down vote accepted

There is an easy but non-obvious way to do this.

Assuming you've got Google sync set up, and you can see your one Google Calendar on your phone already, go to https://www.google.com/calendar/syncselect (it needs the www; it doesn't have to be on your iPhone). You'll see a list of devices you're syncing. Select your iPhone.

On the next screen, you can choose which of your Google Calendars you want to sync with your iPhone. Check the box next to the desired calendars, then hit Done or Save or whatever it says at the bottom.

Open iCal on your iPhone, and give it a while to sync, and you now should see all of your selected Google Calendars on your iPhone.

For some reason, you can't change the colors of the calendars on the iPhone, so I change the colors in Google Calendar to match what the iPhone picks.

There used to be a limit of 5 Google Calendars that you could sync to the phone, but they recently raised the limit to 25.

These same instructions apply to the iPad and iPod touch. I've got this set up on all my devices, and it works like a charm.

This is documented by Google here: http://www.google.com/support/mobile/bin/answer.py?answer=139206

share|improve this answer
    
I'm going to try this right now, this is much better than the way I've been doing it. –  David Aug 26 '10 at 23:05
    
It worked!! I've been waiting for this for months. Thank you so much! –  hpy Aug 27 '10 at 1:45
    
Thanks, this works like a charm. The only thing that's annoying is the colors - even though I've changed the ones in Google to match, my iPhone occasionally forgets about a calendar and then assigns it a different color when it learns about it again. –  Kyle Cronin Sep 4 '10 at 20:52
    
To setup Google Sync in the iPhone: google.com/support/mobile/bin/… –  lpacheco Jan 12 '11 at 10:07
    
This doesn't work for me anymore. Using iOS 4.3.3, Google 2-way-authentication with a generated app-password and google.com/calendar/iphoneselect since the other only works with accounts set to english. I can setup the Exchange things and see my personal calendar. I may also select my other calendars from the URL - but they don't appear... even after hours. Any idea? –  Daniel Bleisteiner Jul 13 '11 at 5:30

I believe you can only do one Google calendar per account to the iPhone. You can sync multiple Google accounts.

Here are some instructions, but I was unable to get it to work: http://www.google.com/support/mobile/bin/answer.py?answer=139206

It would be a nice feature to have.

share|improve this answer

You'll need to create a different account on the iPhone for each calendar, but they can all point to your one Google account...

  1. You probably already know which calendar is the "main" one, as that's the one that the iPhone reads when you add the Google account. You may have to delete that one from the phone (not from Google, of course) for now because sometimes the phone will complain that "you already have an account for this set up."
  2. For each non-main calendar, go to the calendar details on the Google Calendar web site and look for the "ICAL" icon under the "Calendar Address" section.
  3. Add the account on your phone, then edit the details for that account and enter the address from #2 above as the URL for the calendar. (Under Advanced Settings)
  4. Rename the account on the phone accordingly so you know which calendar it is.
  5. Repeat for each non-main calendar.
  6. Finally, add the account as normal for the main calendar.

It's a bit of a hack, and I really wish there was better native support for multiple calendars in all kinds of applications/devices that interface with Google Calendar. But, for now, this has been working really well for me. It's just a pain to set it up in the first place.

share|improve this answer

Spanning Sync allows you to sychronise with your Gmail Apps or regular Gmail account, and will synchronize both Calendar and Contacts between iCal / Address Book and Gmail / Google Calendar.

If you find it useful you can use this code to get a $5 discount on the purchase price HAM46F http://bit.ly/3f3itN

share|improve this answer
    
Yeah I've tried it before, just didn't want to pay for such a solution if I can find a satisfactory free one. Thanks for the tip, though! –  hpy Aug 31 '10 at 21:56

from iphone safari browser:

m.google.com/sync

on the top of the page:

"manage devices"

select what kind of calendar you want to sync

Done

share|improve this answer

I found this buried in Google's CalDAV info after following a rabbit trail. No need to use Google Sync or create multiple accounts on the iPhone!

Syncing Multiple Calendars

By default only your primary calendar will be synced to your device. You can sync additional calendars by visiting the following page from any web browser:

https://www.google.com/calendar/iphoneselect (Google Apps users can go to https://www.google.com/calendar/hosted/your_domain/iphoneselect, replacing 'your_domain' with your actual domain name.) Select the calendars you'd like to sync, and click Save. The selected calendars will display on your device at the time of the next sync.

share|improve this answer

I was able to get multiple google calendars to show on the iPhone 4. I added the first calendar under settings using "Other Account" CalDAV and plugging in my google account details.

When I tried to add another account in the same manner the iphone blocked it.

I then logged into my google account, accessed Calendar Settings for the secondary calendar and found the private URL for ICAL. I copied this URL and then used skype to text message it to my iphone. Once the URL popped up on iphone I clicked it. The phone asked me if I wanted to subscribe to the calendar and I clicked yes.

Boom! Two google calendars on my iphone. One caveat. The secondary calendar cannot be edited from my iphone. But this is no problem for me and I am happy.

share|improve this answer

After syncing you may come across calendars not displaying (for whatever reason), despite them showing up on your calendar list in your calendar app. To remedy this, open Settings.app -> Mail, Contacts, & Calendars -> [your account].

  1. Turn off calendars
  2. Turn on calendars

All your calendars should now show up in the app.

share|improve this answer
    
How does this answer the question? The OP mentioned that the calendars don't show up at all in Calendar.app. –  bassplayer7 Mar 21 '13 at 23:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.