Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm running vmware fusion 5 under OS X Mountain Lion. My virtual machine is running Ubuntu 12.04.

I have two fastidious shortcuts which I would like to disable:

  • When I press Command ⌘, Ubuntu opens the dash and shows under the text field a set of icons.

Command shortcut effect

  • When I press the Option ⌥+` keys (which I use for making accented letters) Ubuntu opens the dash without showing the icons under the text field.

Option+` shortcut effect

How can I disable or block these shortcuts?

share|improve this question
2  
This seems more a question about configuring Ubuntu, or am I mistaking? If so maybe you should ask it on askubuntu.com instead? –  Gerry Sep 11 '12 at 13:09
    
@Gerry I think its valid for both, becuase there some special associations between the keys of a Mac keyboard with the keys of a virtual machine. Btw I would post the same question also there. Is it ok? –  Maverik Sep 11 '12 at 13:33
1  
I don't see how the answer to this question would be any different for Ubuntu virtualized under Windows or under Ubuntu itself for example, so imo it's probably off-topic here. –  Gerry Sep 11 '12 at 13:54
    
I don't agree with you because as I said, vmware decide how the real keys are mapped to the virtualized keeys. So, since the mac have a different keyboard, the case is different from a case in which Ubuntu is virtualized for example on a windows pc. However I posted it on askubuntu.com. –  Maverik Sep 11 '12 at 15:05
add comment

1 Answer

I tried playing around with the keyboard settings in Fusion, in particular editing particular profiles.

This did not change the behaviour of in unity. I did not play around with +` as I could not replicate your Ubuntu behaviour.

The only way I found to disable the shortcut is to install gconf-editor and remove the shortcut from within Ubuntu running the following commands:

sudo apt-get install gconf-editor
gconftool-2 --set /apps/compiz-1/plugins/unityshell/screen0/options/shortcut_overlay --type bool false
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.