Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I installed an app, didn't like it, and then moved it from Applications to the Trash and emptied the trash. Now when I go into the App Store, I am stil being prompted to update the application even though it has been removed.

Picture copy.png

I tried searching the hard drive and I don't see any other copies of the Application.

I also tried running this command which is supposed to update the database of what is actually installed on the system for the App Store:

sudo /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

It is still showing up. How can I get rid of it?

On a related note, I accidentally hid another update that I wanted to install by right clicking on it and choosing "Hide Update". I was not able to hide Clyppan which is the app I'm trying to ditch - but if you do accidentally hide something you want to install, how do you get it back?

Screen shot 2012-09-09 at 12.18.22 PM.png

share|improve this question
1  
I am having the same problem with the app 'IP Scanner". I had it installed on my computer, then did a clean install of the OS and for some reason it kept giving me this update even though I haven't installed it since the OS reinstall. Anyone figured out how to fix this? Also, why can some updates be hidden and not others? –  Sam Sep 28 '12 at 1:47

3 Answers 3

up vote 2 down vote accepted

Does it still show up in Launchpad? Or have you tried downloading the application again and removing it from Launchpad? It runs uninstalld, which doesn't normally remove many other files than the application bundle, but it probably makes some other changes.

share|improve this answer
    
This is a good thought. I tried it but I didn't have any luck. I also did a sudo find command from Terminal and searched the entire hard drive but did not find it anywhere. Is there any way to track down what is making it show up? –  cwd Sep 14 '12 at 22:32
    
Does mdfind clyppan still return some support files? –  ؘؘؘؘ Sep 14 '12 at 22:36
    
hmm - yes it does! Ok I just removed those files and then ran the above lsregister command. it still leaves /private/var/db/receipts/cc.omh.Clyppan.bom and /private/var/db/receipts/cc.omh.Clyppan.plist behind though. and the app is still showing up in the updates section even after restarting the app store and doing killall storeagent –  cwd Sep 14 '12 at 23:18
1  
I don't know. You could try removing it from /Library/Receipts/InstallHistory.plist. –  ؘؘؘؘ Sep 29 '12 at 14:42
1  
Or rebuilding the Spotlight index. –  ؘؘؘؘ Sep 29 '12 at 15:21

Do you have an external drive attached to your mac? There might be a copy of that app on that drive (eg if it were a backup or clone of your main drive).

Alternatively, try going to the 'Purchases' tab, find that app in the list, and right-click > Hide Purchase... and see if that stops it from showing up in the Updates list.

From the Mac App Store help, to see hidden purchases do this:

To view hidden apps, choose Store > View My Account, enter your Apple ID and password, click View Account, and then click View Hidden Purchases. To show a hidden app in the purchased apps list, click its Unhide button

share|improve this answer
    
Hmm, I tried all of these without any luck. +1 for helping me figure out how to unhide hidden purchases. –  cwd Sep 14 '12 at 22:33

just follow these instructions... it worked for me.

http://support.apple.com/kb/ht2409


Spotlight: How to re-index folders or volumes

From the Apple () menu, choose System Preferences. Click Spotlight. Click the Privacy tab. Drag a folder or an entire volume (your hard drive) to the list. If prompted for confirmation, click OK. Remove the item or volume you just added to the list by clicking it and then clicking the minus ("-") button. Close Spotlight preferences. Spotlight will re-index the contents of the folder or volume.

share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

2  
Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone. –  Daniel Lawson Aug 23 '13 at 4:00
    
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  Mark Aug 23 '13 at 9:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.