Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Just got a Mac for the first time...

Under System Preferences > Users & Groups, I have a user profile set as the Admin.

My Full Name and Apple ID are shown correctly. However, when I click on the "Open" button next to "Contacts Card", it thinks that this user profile is associated to the contact card of another member of the family. How do I change that to my own Contact Card?

The consequences of this wrong profile is that whenever I install a new software and I get asked for my name, it keeps putting the name of the family member by default. I also had to go back into my Mail, Contacts & Calendars settings where the full name field was filled out with the family member's name although the accounts were set up correctly.

share|improve this question
    
Actually, I figured it out! I logged onto iCloud.com, clicked on Contacts and there was an option to change the "me" profile to my actual contact card. – Dana Sep 9 '12 at 16:10
    
welcome to the site - can you post your comment here as an answer? (And then you can accept it if you want.) Once it's an answer, we'll delete these comments. – Jaydles Sep 20 '12 at 21:22
    
Is this question specific to OS X? Or is it a problem across your Apple devices? – DGGenuine Nov 7 '15 at 15:45
    
My problem... My own contact card disappeared from time to time. So, the ability to "choose" that contact card was not possible. I had to go to my iMac and choose there. The other possibility was go to iCloud – user158633 Nov 23 '15 at 1:35

You don't need iCloud.com to do this. Open the Contacts application, select your card entry, click on the Card menu, choose "Make this My Card"

share|improve this answer

I ran across this issue when restoring a backup to a new phone. It was showing another family member's contact as My Card under Contacts. iCloud wasn't even signed in.

I had to go into Settings > Mail, Contacts, Calendars. Scroll down to Contacts and select the correct contact under My Info.

iPhone 6 with iOS 9.

share|improve this answer

I know this thread is a bit old, but I've run into a similar issue and this thread is showing high on the search results both here and through Google.

We recently switched to Family Sharing, and the problem was on one of the devices that recently transitioned to a new AppleID. Regardless of the setting for "My Card" on the device, apps still pulled info from the "My Card" of the original shared AppleID.

We could not get the "My Card" setting to stick across the board. The contacts app would show the correct "My Card", but apps would pull data from another card. Also, from time to time, the "My Card" setting in Contacts would switch back to the original card. We had to use the iCloud.Com web interface to make the "My Card" setting stick across the board.

share|improve this answer

Go to setting...mail,contac,calendars.... Scroll down to where is says "my info" select your contact card and you are done. Hope it helps

share|improve this answer

protected by Community Apr 12 at 16:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.