Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Because of missing native equalizer on OS-X (Snow Leopard) I had to use third party app Soundflower in combination with AU Lab. Everything was going right, but once I restarted OS X, the sound stopped working. When I changed the volume by the keys on Macbook I hear the system sound, but in iTunes, Vimeo, some videos on YouTube, Quicktime, etc., I hear nothing.

I tried to remove Soundflower and AU Lab and reboot, but without any change.

Does anybody know how to fix this problem?

share|improve this question
    
When you say you tried to remove Soundflower but without any change, do you mean that Soundflower currently is or is not installed on your system? –  Daniel Lawson Sep 8 '12 at 15:31
3  
Under System Preferences » Sound » Output, what device is currently selected for sound output? –  Daniel Lawson Sep 8 '12 at 15:32
    
Soundflower is not installed on my system. –  Jakub Haluška Sep 8 '12 at 15:32
1  
Did you run the uninstallation script on the disk image or remove /System/Library/Extensions/Soundflower.kext? –  ؘؘؘؘ Sep 9 '12 at 13:01
1  
Run the uninstallation script. –  Jakub Haluška Sep 10 '12 at 14:07

2 Answers 2

If you follow this guide, you should be OK. You mentioned in the comments that you've already run the uninstall script, so perhaps you will be able to follow the guide to success. Before doing that, I would check the following:

  1. Find the 'Audio MIDI Setup' utility (Applications / Audio MIDI Setup), and check all the master volume levels on your output devices.
  2. If you are still passing audio through anything other than regular system audio, check all the levels and knobs and such to make sure that nothing else is turned down to 0.

NB: A common problem people have with Soundflower is the master volume being set to 0 by default.

If none of that is the issue, and you follow the guide, you could try my setup, which is like this:

• Go find AU Lab 2.3, and • Update your Soundflower to 1.6.7 with this fix, available on Github. It has worked for me on Mavericks 10.9.4, it prevents an obnoxious clicking sound as well, and it gives you master faders for Soundflower outputs in the Soundflowerbed dropdown.

NB: If you are not on Mavericks you may not need the updated versions of everything.

share|improve this answer

The only way I've found to fix this is to add new user accout and use it instead of the old one.

share|improve this answer
    
That is the way I dont wanna go :( –  Jakub Haluška Feb 10 '13 at 8:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.