Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My time machine is backup is very slow. Connection is FireWire 800. Transfer is around 5 Mb/s or 0.5 MB/s, which seems slow. I've seen plenty of mention online of very slow Time Machine backups. What are some techniques or suggestions to speed this up?

I have:

  • Run the Disk Utility Repair tool. Everything is fine.
  • Disabled Spotlight on the remote disk

Searching for backupd in system.log gives the following:

13:29:33 Starting standard backup
13:29:33 Backing up to: /Volumes/BACKUP_DISK/Backups.backupdb
13:29:36 Event store UUIDs don't match for volume: Macintosh HD
13:29:36 Waiting for index to be ready (101)
13:29:55 Node requires deep traversal:/ reason:must scan subdirs|new event db|
13:42:53 No pre-backup thinning needed: 39.84 GB requested (including padding), 71.68 GB available
13:42:53 Waiting for index to be ready (100)
14:23:37 Bulk setting Spotlight attributes failed.
14:29:39 Copied 2.0 GB of 28.7 GB, 69560 of 113624 items
15:29:57 Copied 2.8 GB of 28.7 GB, 69560 of 113624 items
16:30:00 Copied 3.3 GB of 28.7 GB, 69560 of 113624 items
17:30:04 Copied 3.8 GB of 28.7 GB, 69560 of 113624 items
18:30:07 Copied 4.3 GB of 28.7 GB, 69560 of 113624 items
18:51:23 Bulk setting Spotlight attributes failed.
19:30:07 Copied 4.8 GB of 28.7 GB, 69999 of 113624 items
20:30:19 Copied 5.4 GB of 28.7 GB, 69999 of 113624 items
21:30:28 Copied 6.2 GB of 28.7 GB, 69999 of 113624 items
21:38:36 Stopping backupd to allow ejection of backup destination disk!
share|improve this question
6  
What is the speed of copying a resonably large file to the disk TM is on? This is to see if TM or the disk is the issue –  Mark Jan 14 '11 at 0:31
    
Transfer rates to the disk are 500 Mb/s == 50 MB/s. Normal FW800 speeds. –  user588 Jan 15 '11 at 3:10
    
Make sure the firmware is bang up to date. Mine wasn't and was slow, but got faster since then. –  AlexW Jan 18 '11 at 23:26
    
What firmware? OS X System Software? OS X EFI updater? I keep up-to-date however Software Updater tells me to, so AFAIK this isn't the issue. –  user588 Jan 18 '11 at 23:42

6 Answers 6

It could also be related to MRT process. For me, when I removed MRT process, backup speed becomes normal. By the way, MRT is sth called malware remove tool which comes with the security update and it will take lots of CPU to do scanning work. There are some articles on how to remove it.

share|improve this answer

This post does not cite any references or sources. Please help improve this post by adding citations to reliable sources. Unsourced material may be challenged and removed.

1  
Rather than mentioning there are "some articles" we prefer someone to answer with those articles summarized and linked so people can understand. The speculation about MRT seems spot on, but is that documented elsewhere either? –  bmike Nov 13 '12 at 22:48

Fragmentation

In my experience, it's very common for the catalog B-tree to become very fragmented. On a volume that is both large and full, this type of fragmentation can have a significant effect.

At any time

Use the demo version of iDefrag to view statistics.

When the backup volume is as close as possible to full

Consider using the Metadata algorithm of the full version of Defrag, or a comparable utility, to defragment the catalog and other critical files.

(For a Time Machine backup volume, don't bother with full defragmentation.)

Other utilities

fileXray — this alone can not defragment the relevant files, but for analysis: I know of nothing better than fileXray.

Cross reference

Do Macs need to be defragmented?

share|improve this answer
up vote 2 down vote accepted

Unfortunately, the solution in this case was:

Format disk (lose old backups)

Now the disk backs up at full speed.

share|improve this answer
    
Was it not formatted as HFS+J? –  Harv Jan 25 '11 at 1:15
    
It was and still is. Nothing changed, just wiped it and everything worked fast. –  user588 Jan 25 '11 at 2:12
    
@mankoff How odd! –  Harv Jan 25 '11 at 6:04
    
It's no surprised that this would improve speed - you started again from scratch. Was the drive previously pretty full? How big is your TM drive compared to the total size of all the disks its backing up? I'd surmise that it was probably spending a ton of time 'thinning', which is throwing out in-between versions of files to make more room for newer versions. Have a look at 'Console' and put 'backupd' in the Search box. Scroll back to before you formatted.. any clues? –  JBRWilkinson Jan 25 '11 at 22:08
    
Good suggestion. Drive was not full. Internal is 300GB used of 500GB. Backup drive was 500GB and had 71GB free. I've posted sample system.log output into the original question rather than here so it can be formatted properly. Doesn't seem to be thinning, but there may have been a spotlight issue, although spotlight was disabled on that drive. –  user588 Jan 25 '11 at 23:52

Add the Time Machine disk to the Privacy list of Spotlight (in System Preferences) so that Spotlight does not spend time accessing that drive.

share|improve this answer

You could try renaming the /.Spotlight-V100 folder on the TM volume. I've never tried this but Spotlight is used to decide which files are new/changed since the last backup. The only thing that comes to mind in reading your question, is maybe the index is broken and needs to be rebuilt, and TM in the mean time is running that search live, rather than indexed.

Long shot.

share|improve this answer
    
Deleting the .Spotlight-V100 folder and adding that drive to the System Prefs > Spotlight > Privacy list seems to have helped. I'll check if this works again on my other slow drive. –  user588 Jan 18 '11 at 20:33
    
If it's worked, great. I'm not sure though if preventing the TM drive from being indexed properly is a good idea though. I suppose once the initial backup is done you could remove the drive from the privacy list and allow it to re-build the index. –  Harv Jan 18 '11 at 21:56
    
Not a good idea? Seems like an obvious flaw that they allow it to be indexed at all. Why would I want spotlight to index the backup drive? –  user588 Jan 19 '11 at 1:17
    
Time Machine makes heavy use of Spotlight to determine which files need to be backed up. –  Harv Jan 19 '11 at 3:46

According to this thread:

Delete the "in progress" folder on the TM drive and then things will operate at a normal speed.

Note: That did not fix the problem in my case.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.