Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

How can I disable the Screen Saver on the login window?

share|improve this question
1  
-1, the accepted solution is unclear. It should indicate what to place in the plist file. –  Gili Nov 18 '12 at 6:18
add comment

migrated from stackoverflow.com Jan 13 '11 at 16:36

This question came from our site for professional and enthusiast programmers.

5 Answers

up vote 4 down vote accepted

You can edit the .plist file at /Library/Preferences/com.apple.screensaver either using a text editor, Plist Editor (requires the OS X Developer Tools) or the defaults command in Terminal to remove the screensaver at login window.

share|improve this answer
1  
how to edit it there? what to add, or what to set, or what to delete? –  Oleg Danu Jan 21 '11 at 7:09
1  
What does your com.apple.screensaver file have in it? Can you post the contents to Pastie? For what its worth, using defaults to read my file returns this and I don't ever get a screensaver. Note however that I'm running 10.6.6, so if your file uses the old (XML) style of .plist, don't sweat it. You could just try trashing the file too. –  Just Jake Jan 21 '11 at 7:16
    
-1, doesn't work for me under Mountain Lion. –  Gili Nov 18 '12 at 6:13
    
The file is a binary plist file (under 10.8 anyway) and to be edited with a text editor must first be converted using plutil -convert xml1 /Library/Preferences/com.apple.screensaver.plist. Then the file can be edited and the screen saver changed. –  Josh Mar 10 '13 at 13:26
add comment

It isn't possible to disable the login screensaver in Mountain Lion due to a bug. According to https://discussions.apple.com/thread/4540671?start=0&tstart=0 the best you can do is log into root's screensaver settings and change it to Message which uses less resources.

See http://apple.stackexchange.com/a/16515/21181 for how to do that.

share|improve this answer
add comment

I believe this does the trick (at least it seems to have worked for mefor several hours now):

sudo defaults write /Library/Preferences/com.apple.screensaver loginWindowIdleTime 0

This disables the screensaver in the loginwindow.

share|improve this answer
1  
I believe this should be the answer since I always use it on my servers. –  Werner Strydom May 20 '13 at 7:43
add comment

Sometimes in Lion, there is either a plist lockfile or an automatic process that rebuilds a new plist file, ensuring that there are defaults for the login screensaver. I believe the system needs the plist file, so instead of deleting the file, you need to make sure that the settings inside that plist file disable the screensaver.

I have had partial success with leaving the plist file alone. The screensaver for the login screen is the one set for the root (i.e. system) user account. To launch System Preferences as root, use sudo. Note that in order to use sudo, you need to be an admin user.

  1. Load a Terminal window and run:

    sudo /Applications/System\ Preferences.app/Contents/MacOS/System\ Preferences

  2. You may see a bunch of errors in the Terminal window, but disregard them.

  3. If the preferences window does not pop up, click the System Preferences icon in the dock once and the window should pop up.

  4. Proceed to change the screensaver settings as you normally would. To turn the screensaver off, move the "Start Screen Saver" time slider all the way to the "Never" on the right.

  5. Once done, close the System Preferences altogether, and then close Terminal.

Further investigation on the plist file indicates three new fields present, and I even changed the screensaver to a different one and noticed the values of the screensaver had changed in the plist file as well.

I just don't see that the screensaver is disabled. This appears to be a bug.

share|improve this answer
add comment

The problem is that the login screen is not the result of the screen saver, I lock my Mac when I go out. The screen saver appears by itself, even if it is disabled from SysPref.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.