Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My MacBook somehow stuck on Mountain Lion Developer Preview 4 (Build 12A256). I downloaded the Golden Master as well as the retail .dmg and tried to install them. The computer does stuff, restarts, but is still on 12A256. I also don't get the 10.8.1 Update in the App Store and if I download it manually and try to install it all I get is:

OS X update cannot be installed on this disk. This volume does not meet the requirements for this update

Do you have any idea how I get out of this mess without a clean install (because that's kind of tricky because I have 2 hard drives)?

share|improve this question

closed as off topic by CajunLuke, Stu Wilson, patrix, daviesgeek, jmlumpkin Sep 21 '12 at 12:58

Questions on Ask Different are expected to relate to Apple hardware or software within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

That’s odd. I installed retail over DP 4, and it works flawlessly. The only difference was that I installed from a USB drive, rather than the traditional app based method. – duci9y Sep 5 '12 at 14:28
Thanks, using an USB-Stick I got some interesting log files and after some googling I found out I had to reset my PRAM. – optikfluffel Sep 6 '12 at 9:15
Will you accept that as an answer? – duci9y Sep 6 '12 at 9:41

Try running disk utility on your hard drive first then try the update. Take a look at this link,

share|improve this answer
As I wrote resetting my PRAM worked for me :) – optikfluffel Sep 10 '12 at 15:06
You know, on unknown reason reseting PRAM does not work for me... – Antonio Sep 10 '12 at 20:15
While the link you posted may answer the question, it is best to summarize the contents of the link in your answer, then provide the link for reference. Links have a tendency disappear over time, leaving a non-applicable answer for those who may stumble upon your answer in the future. – daviesgeek Sep 28 '12 at 5:28

After resetting my PRAM using Command ⌘+Option ⌥+P+R at boot I could install the update using a bootable USB drive.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.