Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Since updating to Mountain Lion, the keyboard shortcut for cycling through windows is not working for me in Terminal (and is driving me nuts!).

Is there any known fix for this issue? The keyboard shortcut shows up on the Window menu as expected, but doesn't work.

I am, of couse, pressing CMD-`, and is not cycling. Selecting the option from the Window menu does cycle through the windows, though.

Update: Although not resolved in Mountain Lion, this got fixed in Mavericks. It was weird: it works properly on Lion and Mavericks, but breaks on Mountain Lion.

share|improve this question
    
I have exactly the same problem. The only thing I noticed is that I've got 2 keyboard layouts on my computer (english and international-english) this problem occurs for me only when I'm using the international-english kbd layout.... Is it the same with you? –  AndreDurao Oct 19 '12 at 11:22
    
BTW When I'm on intl-eng layout the cycling shortcut is mapped on cmd+"["... –  AndreDurao Oct 19 '12 at 11:31

3 Answers 3

Are you getting 'cycle through windows' confused with 'cycle through tabs'?

Cycle Through Windows shortcut is CMD-` where Cycle Through Tabs is CMD-}

share|improve this answer
    
No. As I stated, I'm doing CMD-`. It was fixed in Mavericks. –  pgb Feb 4 at 12:48

Check the Keyboard Shortcuts tab of the Keyboard System Preference-- make sure that Move focus to next window is set to your liking (in the Keyboard & Text item) and that there are no conflicts with any other shortcut settings. Barring that, a complete re-install of ML has fixed other quirks that cropped up when I upgraded.

share|improve this answer
    
The shortcut is properly set. It turns out to be a bug with the US International keyboard. Changing to US fixes the issue. –  pgb Jan 15 '13 at 19:23

I've been using MoLion for months and have never experienced this issue (and I would have). I tested this again just now with several terminal windows open, and no issue.

You are pressing cmd - ` , right?

share|improve this answer
    
Of course I am :) –  pgb Sep 5 '12 at 11:51
    
Then you've got me :) –  camflan Sep 5 '12 at 13:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.