Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I just upgraded to Mountain Lion and I'm perplexed to find that neither iTerm 2 or the standard terminal will not receive Control ⌃+ or +, which I typically use to jump words on the command line. I can, however, use + and + which I'm finding odd.

I've tested this by opening up cat on stdin and mashing buttons. My initial guess is that OS X is intercepting them somehow, I suspected Spaces (I guess it's part of Mission Control now) at first, but after disabling all key combinations for it, I've come up empty-handed.

Has anyone ever seen this before, or does anyone have any other ideas?

share|improve this question
add comment

2 Answers 2

optionf - Jump Forward a Word

optionb - Jump Back a Word

From the bash manpage:

   forward-word (M-f)
         Move forward to the end of the next word.  Words are composed of alphanumeric characters (letters and digits).
  backward-word (M-b)
         Move back to the start of the current or previous word.  Words are composed of alphanumeric characters (letters and digits).

If you open up Terminal.app (the OS X built-in terminal), open preferences, choose the 'Settings' section, and click 'Keyboard' in the navigation strip.

Terminal Keyboard Preferences

The shortcut is defined here. It may be possible to modify that, or I would suggest duplicating it, using control cursor left with the same \033b action, and control cursor right with \033f.

share|improve this answer
    
This doesn't help that the terminal won't respond to ^← or ^→. I know how to bind keys to actions, but I don't know why the terminal isn't responding to the keys being pressed. –  jordanstephens Sep 4 '12 at 21:52
    
I think you should file a Radar that even when you disable the shortcut, something still traps it. –  Jason Salaz Sep 5 '12 at 1:34
    
I can verify that Terminal will respond to Control-Left/Right if they aren't intercepted elsewhere. The default Terminal keyboard map even includes mappings for them, and they work if I turn off the Mission Control shortcuts. –  Chris Page Jan 16 '13 at 14:08
add comment

This is because ctrl+ and ctrl+ are bound to changing spaces in Mission Control.

Keyboard Shortcuts

share|improve this answer
    
The OP's question indicates that he's removed those shortcuts. –  Jason Salaz Sep 5 '12 at 1:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.