Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Snow Leopard: My Mac doesn't recognize my Samsung Galaxy S2 over USB, and it's starting to drive me nuts.

I've tried the following:

Connect Storage to PC

Settings > Wireless and Networks > USB Utilities > Connect Storage to PC

I've tried this several times on my phone, following the procedure stating that I should only connect after the phone asks me to, but it does not work.

There is no "attach-button" in the pull down menu, like some claim there should be. Yet it seems that the phone notices that the USB-cable is connected. However OS X does not. No external storage pops up in Finder. I've also tried waiting for several minutes as I know this sometimes can take a while, but to no avail.

USB Debugging

Settings > Applications > Development > USB debugging

When set to on, nothing happens. When set to off, nothing happens either. (It is automatically shut off when using Connect Storage to PC.)

Android File Transfer

I've also downloaded Android File Transfer, and while the phone finally recognized something by stating MTP-Connected in the pull-down menu, nothing happens in OS X, nor the Android File Transfer program itself.

I've also tried it in conjunction with both USB Debugging on and off, to no avail. When it's on, the phone doesn't detect any MTP. When it's off, the phone detects MTP. Either way, it seems that OS X doesn't detect jack...


Please do not post answers suggesting the use of Kies, Bluetooth, Wireless, and the like. I want my phone to work over USB for a reason (speed and convenience).

share|improve this question
    
Have you looked in the System Information utility to look at the raw USB connection status? That window can be handy to troubleshoot a hardware connection issue or at least let you know it's software. OS X can take a while to check attached storage to determine the filesystem status - so if the device is changing how it exposes itself to the system I could see it not mounting storage due to a timing issue. –  bmike Sep 4 '12 at 14:19
    
I have now. The "universal" answer from USB Prober is ` AppleUSBOHCI[0x56f9800]::SuspendUSBBus Processing WDH before suspending`. –  Kebman Sep 4 '12 at 14:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.