Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In Mountain Lion's Notification Centre, I don't like having a notification pop up with the contents of an iMessage text I just got, but I do want to have notifications about it happening.

Is there a way to make it just show a notification without the content, similar to the iOS setting to not "Show preview" that hides the text content from the iOS notification center?

share|improve this question
add comment

2 Answers 2

This is not possible with the currently available notification options and configuration of Notification Centre. The three options you have are

  • No notifications
  • Banner
  • Banners that stay until clicked

You have no control over the content of the message, its just shows what is sent by the notifying application.

So looking at iMessages, there is no way to change or limit the notifications that are sent by default to the Notification Centre.

So the only solution I can come up with is to turn off iMessage notifications completely in Notification Centre

Then using iMessage's built in ability to run Applescripts when events are triggered, then send your own notifications without the offending content (more private IMHO for work machines) to Notification Centre by using third party scripts.

Of course, those notifications would have your own defined content and would also have to come from an application that is enabled in Notification Centre.

This thread might give you a start on how to create a notification that can be called from Applescript.

share|improve this answer
add comment

There is an option to "show preview" that can be ticked off in the settings of the Messages app: Go to Settings> Notification> Messaging.

Stated another way:

1) Go to Settings = "Click on the GEAR" (System Preferences)

2) The top-most section of System Preferences on My Mac is labeled "Personal" at the far right is "Notifications" (a black square with a red dot in the center)

3) Click that square and the dialogue window will show a list on the left which should include "Messages" with a sub title "Badges and Sounds"

4) Click that item in the list on the left and you will notice on the right side, toward the top it has three options (the default is Banners). Click the item to the left of Banners (should be None).

Now you can press CMD+Q on your keyboard to close System Prefs and the alerts will stop popping up in the upper right of your screen (you may want to test it)

This was an issue for me because I was allowing one of my staff to use my Macbook for some training and all my personal iMessages kept poppng up in fromt of her - NOT COOL. This ended that problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.