Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

After migrating from one computer to another, my iPhone now automatically appears under the devices list in iTunes on both my old and new Macs. I don't want to accidentally sync my iPhone with my old computer. Is there a way I can make it forget it knows my iPhone?

I've tried:

  • Turning off wifi sync on the old computer, but this is a device-level setting, so as soon as you turn it back on on the new computer, the iPhone shows on both.
  • On the old computer, deleting all device backups, 'ejecting' the iPhone from iTunes, and forgetting all remotes. None of those measures has had an effect.

Presumably I need to nix some folder deep in iTunes' lair. Any ideas?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Reset the SyncServices folder. Not sure why I didn't think of this earlier.

In short:

/System/Library/Frameworks/SyncServices.framework/Versions/A/Resources/resetsync.pl full

Apple has some other tricks to try if you're on an OS prior to Mountain Lion, but it looks like this should work for Leopard through Mountain Lion.

You can confirm by comparing output of

grep -ir "device" ~/Library/Application\ Support/SyncServices

before and after resetting the SyncServices folder. You should see some lines about your device prior and no lines about it after.

share|improve this answer
1  
I can't find resetsync.pl in Mavericks. This support articles doesn't list anything about Mavericks either support.apple.com/kb/TS1627?viewlocale=en_US&locale=en_US –  Steve Moser Oct 27 '13 at 16:01
add comment

If you go to the iTunes > Preferences menu and select the Devices tab you can delete backup's from particular iPhones. Also you can go to iTunes > Preferences > Devices, and check the box 'Prevent iPods. iPhones, and iPads from synching automatically'.

share|improve this answer
    
Sadly I've tried these and neither prevents the iPhone from showing under Devices. –  duozmo Sep 7 '12 at 22:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.