Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

If and only if my MBP is plugged in to both AC and an external DVI monitor, it will hibernate instead of sleeping. If it is not plugged in to the monitor, it will sleep like normal.

I have a 15" MBP, 2.2 Ghz, running OS 10.8.2, with a USB mouse attached, as well as a USB HD and FW Time Machine disk, connected to the monitor via an Apple Thunderbolt-DVI adapter into a DVI cable, with both displays running. It doesn't matter which way the machine sleeps, they all yield the same problem. The console has no weird messages. And disabling sleep is NOT a viable option.

What is causing this abnormal behavior and how can I prevent it (without disable hibernation entirely)?


I followed the instructions to completely disable hibernate, and have run into an even worse issue. When put to sleep attached to the DVI monitor, the machine will completely shut down. What will let my machine sleep normally?

share|improve this question
    
How big is the monitor? the MBP can only power screens of a certain size without that $100 adapter. Since the intention of the mac hibernation mode is to be activated when the battery is nearly empty, I'd assume this monitor is draining a lot of power or draining power oddly and glitching your mac.. have another monitor? worth a shot testing at least. –  Ryan Hollingsworth Oct 9 '12 at 12:34
    
It's a 1600x900 monitor, and the Mac will have full or nearly full battery when this happens, so I doubt it's that. –  segiddins Oct 9 '12 at 20:17
    
sorry i should've been more clear.. the inch size matters. I was able to plug my MBP into a 30inch display but had a lot of issues b/c it couldn't power it.. may be similar. just a thought. –  Ryan Hollingsworth Oct 9 '12 at 20:35
    
I think its about a 17", again nothing too extravagant. –  segiddins Oct 9 '12 at 20:46
    
The oddest part of this story is that it only happens when plugged into AC. Are you sure this doesn't happen on battery power? –  Old Pro Oct 20 '12 at 20:10

3 Answers 3

Okay first of all, check if you have Hibernation set up on Hot Corners.

Have you tried going into:

1.System Preferences

2.Energy Saver

3.Power Adapter Tab.

4.See if the Put the hard disk to sleep when possible is checked if so - uncheck it.

Try it and let me know if it works.

share|improve this answer
1  
Hibernation on Hot Corners? I don't think this is possible (or practical, in Apple's case) Surely, you mean "Put display to sleep" –  Ethan Lee Oct 9 '12 at 4:58
    
True, you can't have Hibernation on HotCorners. No, I mean Put the hard disk to sleep when possible because that's what makes your laptop hibernate. Uncheck it if it's checked on the PowerAdapter tab. –  Atanas Bozhkov Oct 9 '12 at 11:43
1  
OK I will try with Put the hard disk to sleep when possible disable for when on AC power –  segiddins Oct 9 '12 at 20:18
    
Doesn't work. tried it and it still hibernated –  segiddins Oct 13 '12 at 1:32

First, try disabling hibernation (safe sleep) entirely:

sudo pmset -a hibernatemode 0

Then, to remove any trace of other previous hibernations, run:

rm /private/var/vm/sleepimage to free ~4 GB (in my iMac's case)

Should you ever want to turn Safe Sleep back on, run sudo pmset -a hibernatemode 3

If you want to manage all of this with a simple System Preferences pane and it's worth four dollars for you, there's always SmartSleep.

share|improve this answer
    
edited question-I dont want to disable hibernation entirely –  segiddins Oct 9 '12 at 20:19
    
It doesn't work. See edited question –  segiddins Oct 15 '12 at 23:32

Well, it's hard to be sure since you haven't given the full specs of your setup

I am guessing the problem is because your MBP has 2 GPUs ("graphics cards") (a discrete one and an integrated one) and there's some issue with the discrete one going to sleep that is causing the OS to give up on it.

Obviously the first option is to disable sleep, but not really a solution.

Next, check the Console (All Message) and look for any messages that happen when you put the computer to sleep. I expect you will find some sort of error message that may help us figure out exactly what the problem is.

If the console messages don't help, then I recommend you install gfxCardStatus and see if it makes a difference whether you are using the integrated or the discrete GPUs. If it's only a problem with one then you can stick with the other, or complain to Apple that the GPU is broken and see if they will fix/swap the hardware.

share|improve this answer
    
I have a 15" MBP, 2.2 Ghz, running OS 10.8.2, with a USB mouse attached, as well as a USB HD and FW Time Machine disk, connected to the monitor via an Apple Thunderbolt-DVI adapter into a DVI cable, with both displays running. It doesn't matter which way the machine sleeps, they all yield the same problem. –  segiddins Oct 15 '12 at 19:43
    
Console has no weird messages. And disabling sleep is NOT a viable option. –  segiddins Oct 15 '12 at 19:44
    
@segiddins I recommend you install gfxCardStatus and see if it happens both when you are using the integrated and the discrete GPUs or if it is only a problem with one or the other. If it's only a problem with 1, then you can stick with the other, or complain to Apple that the other GPU is broken and see if they will fix/swap the hardware. –  Old Pro Oct 15 '12 at 20:36
    
gfx.io/release-notes/2.3.html New version release notes says "Fixed some of the issues with sleep people were seeing". Maybe that was the issue? I didn't keep gfxCardStatus open, but maybe that was the problem? Also, using an external display on my particular machine requires using the dedicated graphics card. –  segiddins Oct 15 '12 at 23:37
    
@segiddins, I'm not surprised the external display requires the dedicated GPU. I suspect the sleep issues are due to trying to switch to the integrated GPU before sleeping. Please let us know how gfx 2.3 works or if uninstalling it fixes the problem. –  Old Pro Oct 16 '12 at 6:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.