Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I know that there's Window>Scale>100/75/50% but the scale of the retina iPad simulator is still too big for my screen to be able to test anything.

Is there a way I can scale the size of the iOS simulator smaller than one of the default values? I need it to scale down at least to 25% for my screen size to accommodate the window.

share|improve this question
    
I think you tagged it appropriately. I did add the ios-simulator tag as I think it is possible it could be used by others. –  bassplayer7 Sep 1 '12 at 19:25

2 Answers 2

up vote 3 down vote accepted
+50

You can't. I've been an iOS software developer for two years and I haven't been able to find a way do this. I have tried to find solutions to this but came up with nothing. I'd love to be proven wrong, but I'm 99% certain there's no way to do this.

When my screen is too small I use 50% scale window, which is ought to be enough until I hook up my big monitor again at home.

share|improve this answer
1  
Confirmed; has to do with a rendering issue if you could resize it stackoverflow.com/questions/1446135/… –  Ethan Lee Sep 5 '12 at 5:41
    
New update in iOS SDK now allows scaling, see my answer below. –  Nicholas Jul 26 at 23:30
    
@Nicholas OP knew he could scale to 50% or 75% of the size, he was wondering if he can go smaller like 25%. –  Enrico Susatyo Jul 27 at 3:16
    
My bad, over read that. Have deleted my answer :) –  Nicholas Jul 27 at 4:28

You can scale iOS simulator to desire scale (I tried from .2 to 1.4 ) and it worked for me.

To do this you have to go to /Library/Preferences and edit com.apple.iphonesimulator.plist file. Edit value for KEY SimulatorWindowLastScale to desire scale.

I tried this on latest Version of Mountain Lion (10.8.4) and on the iOS 6.0 simulator.

share|improve this answer
1  
On my setup, using Xcode 5 from the App Store, the fine is located in the path ~/Library/Preferences. Modified it as explained and it worked fine. For me, .4 was the magic number to make the iPad fit properly on my screen. –  JMack Oct 14 '13 at 22:58
    
This should be the accepted best answer. –  Stevko Aug 5 at 16:46
    
I had inconsistent results with the simulator in Xcode 6, but ultimately it does still seem to work. defaults write ~/Library/Preferences/com.apple.iphonesimulator SimulatorWindowLastScale "0.4" –  JMack Sep 11 at 8:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.