Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an iMac(27" from 2010) and while running Lion I tried to HiDPI modes that gives me 1280x720 and larger text. I did change back to 2560x1440 long before upgrading my system to Mountain Lion.

If I use the screen saver, or switch to the "select user to login" main screen, and then back to my user account, my windows are resized to fit inside a rectangle that looks like 1280x720. This behavior happened in Lion too and the upgrade didn't change that.

Any idea on how I can get rid of this behavior? I haven't found any .plist file to delete that seemed relevant.

share|improve this question
I would definitely try measuring to ascertain that it is resizing to exactly 1280x720. I am also updating my answer with more related plists. If none work, try a re-install. – Ethan Lee Oct 6 '12 at 22:37
knowing the name of your screen saver would also help – Ethan Lee Oct 6 '12 at 22:44
I'm not entirely sure it's a specific screen saver. This happens mostly when I've switched users. – Tommy Oct 7 '12 at 8:22
Still happening on Yosemite <sigh> – w00t Aug 27 '15 at 13:54
up vote 0 down vote accepted

A few suggestions in terms of plist files worth trying to move to the desktop and rebooting for before I suggest a ML re-install.

~/Library/Preferences/ByHost/ (just search 'windowserver' in the Preferences folder)

~/Library/Preferences/ByHost/ (again, just search for 'display' in the Preferences folder)


update more property list files to try to help:

~/Library/Preferences/ByHost/ (search 'screensaver' in Preferences)


Also, search the name of your screen saver in Preferences to see if that particular screen saver is remembering your last screen size.

Lastly, try resetting your PRAM (Command-Option-P-R) after boot chime.

As a very last measure I would try re-installing Mountain Lion. Good luck!

share|improve this answer
Thanks Ethan! This did the trick! I booted up in single-user mode and removed those files in all the users' Library folders. Then I did a PRAM reset and rebooted. – Tommy Sep 25 '12 at 15:31
Nope, it happened today again. Anyway, thanks for trying to help. – Tommy Sep 29 '12 at 19:48
Did you try their correspondents in the root library folder (/Library/Preferences) – Ethan Lee Sep 29 '12 at 21:52
Yes, it still happened. – Tommy Oct 4 '12 at 12:45

I changed the resolution to 1024x768, logged out, rebooted, logged in. Changed to 2560x1440 and logged out and rebooted. That seemed to have fixed it.

EDIT: No, it didn't fix anything.

share|improve this answer

So this happened with Lion and you had hoped it would go away with Mt Lion? I've been there too, different problem, but these soft upgrades don't always resolve them. (my issue was emptying the trash took hours and ran my CPU at 145% for the entire time, no one at apple knew what to do, eek!)

Here's how i solved my bug. Backed up all my files, and did a clean install of OSX. When you upgrade to Lion or Mt Lion the installer creates a small backup partition on your harddrive which you can access by rebooting your computer and holding down the alt key. Keep holding the alt key until your greeted by a screen with your HD and the restore partition, select the restore and make sure you wipe the harddrive.

That may take a few hours, but if it's not a hardware issue it's stands a great chance to solve your issue. Good luck!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.