Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Security settings are set to "Mac App Store and identified developers". I'm still getting this problem though I've allowed the app to run more than once as an Administrator. Specific apps that are experiencing this problem are Coda 2 by Panic, PDFpenPro by Smile Software, and Firefox.

"Coda 2" is an application downloaded fro the Internet. Are you sure you want to open it? Safari downloaded this file on August 29, 2012

Panic and Smile Software are identified developers if I'm not mistaken. And Transmit by Panic opens fine without these warnings.

Any idea why this is the case?

share|improve this question
And this is every time you launch these apps even after confirming the dialog? I'd try Repair Disk Permissions first in Disk Utility. – Gerry Sep 1 '12 at 8:37
@Gerry just tried that and found some permissions errors but unfortunately the problem still persists :( – blogjunkie Sep 1 '12 at 9:12
Have you tried rebuilding the Launch Services database? – user495470 Sep 1 '12 at 9:16
Tried that and I got: -bash: /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchSe‌​rvices.framework/Versions/A/Support/lsregister: No such file or directory Is that the correct command? I'd appreciate it if you could repost in – blogjunkie Sep 1 '12 at 9:20
I edited the comment a few minutes after sending it. Stack Exchange inserts ZERO-WIDTH NON-JOINER characters in the middle of long strings without spaces. – user495470 Sep 1 '12 at 11:44

Solved the problem! The quarantine metadata was not clearing correctly for some reason. I fixed this by doing:

sudo xattr -d /Applications/Coda\

Big thanks to Thomas Reed in the Apple discussion forums - Link to answer.

share|improve this answer
Thanks! That was getting annoying---for me it was Adium – Dolan Antenucci Mar 30 '13 at 10:23
This was the answer I was looking for; it worked perfectly! Thank you. – bluebinary Apr 1 at 5:01

If other applications keep showing the dialogs, you could also try disabling the quarantine warnings completely with defaults write LSQuarantine -bool false. It also disables the warnings shown by Gatekeeper even if it was enabled in System Preferences.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.