Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I plug my MacBook into my external keyboard at work, the keyboard viewer window automatically opens up.

How do I prevent the keyboard viewer from automatically showing?

If possible, I'd like to keep the input sources menu bar item visible (the little American flag on the menu bar).

EDIT: i'm on mountain lion, i've got the viewer un-checked, and i'm still getting the viewer: enter image description here

share|improve this question
up vote 1 down vote accepted

The appropriate checbox in the System Preferences... > Keyboard.

Keyboard preferences screenshot

share|improve this answer

This problem hasn’t bothered me for some time, but I remember it used to occur (though I couldn’t pinpoint the exact circumstances). I have tried two different things:

  1. After invoking the Keyboard Viewer, don’t close it by clicking the red close window button, but by clicking Hide Keyboard Viewer on the Input Menu in the menu bar.
  2. If that doesn’t help, try deleting the Keyboard Viewer preference file: ~/Library/Preferences/com.apple.KeyboardViewer.plist.
share|improve this answer

Go to System Preferences > Language & Text > Input Sources. Then uncheck Keyboard Viewer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.