Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm using the Microsoft Remote Desktop Connection tool with my MBP retina to connect to a Win7 system, but I can't get the resolution over 1440 x 900, even in full screen mode. Is this a limitation, or am I doing something wrong?

Changing the Retina display scaling didn't seem to make a difference.

I tried Cord instead, and while that seems to support other resolutions, the quality seems terrible.

share|improve this question
    
Is the app Retina ready? –  duci9y Aug 31 '12 at 9:07

5 Answers 5

up vote 5 down vote accepted

Sorry, you're fresh outta luck here, unless Microsoft re-writes RDC to support Retina.

Basically, what's happening is that OS X is detecting that the app isn't retina-aware, reporting a 1440x900 screen size to the app, then pixel-doubles the app's output.

This is the same as what happens when you run a (non-retina) iPhone app on an iPad in "2x" mode, it just pixel doubles, and the app doesn't know any different.

Great for compatibility, not so great for graphic quality...

I would suggest (to everyone!) to submit as a bug/feature request to Microsoft. If enough people complain, they might just do something about it.

Hope this helps.

EDIT: You might want to give Jump Desktop a try. It's been updated for Retina as at 18th August. At $30 or so, it's a tad expensive for my limited use, but it sounds like your best bet. Cheers!

share|improve this answer
    
The answer is wrong, app supports retina, because text is clear. Text on apps which don't support retina are pixelated. –  kreker Jul 10 '13 at 7:39
    
No, Jump Desktop does not handle Retina well. support.jumpdesktop.com/entries/… –  Skou Sep 30 at 19:43

Buy 'Jump Desktop (Remote Desktop)' from the App Store. It solves the lag caused by the retina display...I had the same problem and it was doing my head in. It also makes the resolution look a lot better than the Windows RDC software.

share|improve this answer
    
Are you satisfied with Jump Desktop? –  alp Nov 2 '12 at 22:35

Are you sure you've installed the correct drivers?

According to the support pages of the Retina Mac:

Is Windows 7 using Boot Camp supported on the Retina display?
Yes. You will need to download and install the Windows Support Software using the Boot Camp Assistant to use the Retina display with Windows 7. For more information see this document.

You can open Boot Camp Assistant and download the software there.

share|improve this answer
    
My question is about remote desktops (i.e. an external PC) , rather than VM or bootcamp. I have Win 7 bootcamp up and running, and that works amazingly well. –  Roddy Sep 3 '12 at 13:21

I was able to force RDC to accept other resolutions. I already knew in advance that forcing the desktop to Macbook Pro's Retina 2800 x 1800 would cause problems if you weren't able to adjust the text and item size (some Terminal Server setups won't allow display changes - my client's doesn't)

The goal is to get a good-sized piece of real estate with legible text and icons.

  1. RDC Preferences/Display, change resolution to any value OTHER than “Full Screen”
  2. Close preferences dialog
  3. Save the RDP file
  4. Open Finder, find the RDP file you just created; Open with TextEdit.app
  5. Find the DesktopHeight and DesktopWidth tags, change the values in the integer tags immediately below to values you want. In my case, I picked DeskTopHeight 1280, DesktopWidth 2048 (nice round hex values, 1 x 1.6 ratio like MacBook Pro’s Retina display of 1800 X 2880)
  6. Save RDP file
  7. Open the RDP file you just edited with RDC
  8. RDC View menu, select Full screen (until you go full screen, it will not be retina resolution).
  9. In the Windows RDP session you just started, run Control Panel\Display\Adjust ClearType text

I have a pretty nice work surface now; looking forward to trying it out tomorrow. I wish I knew if RDC kept the display resolutions for Preferences in a file somewhere, I’d add 2048 x 1280 in there.

share|improve this answer

Go to rdp settings, add the full screen resolution of your mac. Go to connection and choose that resolution. Enable scaling. Looks exactly like Jump

share|improve this answer
    
Thanks! It was helpful to know that Full Screen Mode: Custom, and √ Scale content would force the resolution to full (I had 2880 x 1800). –  Colin Aug 31 at 22:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.