Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Lately, my Magsafe power adapter has not been connecting properly:

  • The wires are not worn out as I take good care of them
  • The issue happens when I try to connect my power adapter to my computer
  • The LED does not come on and the MacBook does not get charged. I have to unplug and plug the power adapter several times until I can get a connection.
  • The cord and computer intake seem clean and no pins are pushed down

What can I do?

share|improve this question

5 Answers 5

up vote 3 down vote accepted

Even if there isn't any obvious cable damage or bulging, the adapter could be failing. If the adapter is not one of the newer L-Shape Magsafe plugs, the need for a SMC firmware update is moot, but it's helpful to have the system up to date regardless.

Have you confirmed if a second, known-good adapter works on your Mac?

Updated: An SMC reset can also correct magsafe LED issues. http://support.apple.com/kb/HT3964

share|improve this answer
    
+1 for "Have you confirmed if a second, known-good adapter works on your Mac?" That should be the first step and the firmware upgrade the last. –  Philip Regan Jan 12 '11 at 12:45

When I had a problem like this (the light would not come on and the menu bar status icon said “Not Charging”), I called AppleCare and they chose to replace the power adapter, and the problem did not reoccur.

share|improve this answer

Do you restart your computer regularly? If not, you may want to try that. I suggest this because my early 2011 MacBook Pro's Magsafe indicator did not light up yesterday when I plugged it in. This is the first time that I've seen this. I tried several times and it did not light up and charging was not detected on the menu bar icon.

After doing a full system reboot, everything was fine, though.

I'm not suggesting this will solve the problem, but it may be worth trying.

share|improve this answer
    
thanks for the FYI –  dassouki Aug 8 '11 at 18:31

Your MagSafe power adapter could require frequent reset because of an external problem: the electrical wiring in your home is substandard, and/or the power provided by your electrical company is sending "dirty" current out of your wall outlet and into your MagSafe adapter. This official Apple support document refers to this problem as "line noise issues".

This means that the alternating current (AC) is irregular, and the MagSafe adapter cannot handle it. The best way to test for this is to use your MagSafe adapter and your MacBook at another location, possibly in another neighborhood, in a house or business where the electrical wiring is newer. If the problem goes away, this is an indication that the electrical wiring and electrical service in your home are substandard.

Fixing this would of course be an expensive proposition, and involve the services of a professional electrical contractor to retrofit the electrical system in your home or business, or to install expensive power conditioning equipment.

share|improve this answer
    
The same support document says: "Unplug the power adapter from the wall, let it sit for 60 seconds, then plug the adapter back in." This often helps me. –  spudwaffle Aug 10 '11 at 23:33

Make sure you have the newest SMC firmware. This controls connecting to the MagSafe and charging.

Use this Apple page to see if there are any updates available.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.