Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In system preferences, if I click the "lock" icon to allow me to make changes as the administrator, no dialog opens. The message "Authenticating..." appears momentarily, then disappears, and the lock stays locked.

I'm on OS X 10.6.8.

Any idea what could cause this or how to fix it?

share|improve this question
Are you an administrator, regular/limited user, or guest user? – CajunLuke Aug 29 '12 at 18:20
Administrator.. – keflavich Aug 29 '12 at 19:43

5 Answers 5

I've had this same issue for months. Before it was my old MBP since "upgrading" from Snow Leopard to Lion, and now again on my brand new MBP with Mountain Lion. After some digging it looks like a fairly common problem, possibly to do with CAC/ID card readers.

Anyway, this worked for me (without a reboot!). From Terminal:

sudo pkill -HUP securityd

When I did this Mail apparently lost it's connection to the security framework and started prompting me for passwords; I just restarted it and it was good to go.

share|improve this answer
Interesting - I'd like to try this, but I already fixed my problem by deleting all of my preferences and rebooting. I'll try next time around... – keflavich Sep 27 '12 at 1:03
Hm. I wish that worked for me. Deleting my prefs and rebooting did nothing, so it's either because we have different environments or different problems entirely. Oh well. – MisterEd Sep 27 '12 at 23:35
It worked for me without rebooting! – Pavel Nikolov Mar 7 '13 at 19:57
+1 worked also for me. And yes, my problem is related to CAC/ID card reader (Estonian ID card). So I can confirm that this solution works if your issues are also related to CAC/ID card reader. FYI: I'm on OSX 10.7.5. – Neeme Praks Apr 23 '13 at 19:08
BTW, "pkill" is not available on OSX by default (at least not on 10.7.5), you can use "killall" for the same purpose: sudo killall -HUP securityd – Neeme Praks Apr 23 '13 at 19:11

It sounds as an issue either with permissions or keychains. Try repairing them both.

To check Keychains for problems just:

  1. Locate the Keychain Access application, under /Applications/Utilities.
  2. Choose Keychain Access > Keychain First Aid.
  3. Enter your User name and Password.
  4. Select Verify and click Start.
  5. If any problems were found, select Repair and click Start again.
share|improve this answer
That's great to know about it. I did the verify & repair (though nothing was reported to be wrong), but unfortunately it did not fix (or in any way change) the problem. – keflavich Aug 29 '12 at 19:55

This issue has something to do with authd. You can just kill or force authd to quit like this (in Terminal on Mavericks):

sudo pkill -HUP authd

(when prompted, type your password.)

Just killing securityd doesn't work on Mavericks.

share|improve this answer

I has the same as original problem after latest update to 10.10.3 killing the authd as this:

sudo pkill -HUP authd

and checking with the terminal and 'ps -ef | egrep "authd|securityd" showed that is was restarted immediately. But this did not change the behavior.

Then I tried the same with the target of securityd,

sudo pkill -HUP securityd

afterwards, it is still not running, but then I did not check before hand and so I don't know whether it WAS running previously. But there is a new behaviour>

When I click the lock icon to unlock access to change the Sys Preferences, it does NOT respond at all - no brief message about authenticating.

That what I get for poking around in the dark :-)

A system reboot will be happening as soon as convenient (reach a good stopping point).

share|improve this answer

My Security & Privacy wouldn't unlock either. I had no password set on my account when this was happening. I went to Accounts and set an arbitrary password and I was able to finally unlock the pane. Afterward, I just reset the password back to being no password.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.