Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have recently upgraded to mountain lion and every time I start a new tmux session, I get the following warning:

│warning: unsupported new OS, trying as if it were 10.6-10.7

Is this anything I should be worried about?

share|improve this question
add comment

migrated from serverfault.com Aug 29 '12 at 13:01

This question came from our site for professional system and network administrators.

2 Answers

That message comes from my reattach-to-user-namespace wrapper program that let’s you (e.g.) access the pasteboard inside tmux. You are using an old version of the wrapper (from prior to Mountain Lion).

The old wrapper does work correctly under 10.8; the message just means that you are using a version from before 10.8 was available/verified. So there is nothing to worry about, but it may get annoying seeing the message every time you start a new tmux pane/window.

To get rid of the message, you should upgrade to a newer version of the wrapper. If you previously installed via MacPorts of Homebrew, just upgrade via that package manager. Otherwise, download the latest tagged source (or pull into your previous Git clone), rebuild it (e.g. type make), and copy it to the location that your tmux default-command setting uses.

Both MacPorts and Homebrew currently package the 1.1 version, which suppresses the message when running on Mountain Lion. The 2.0 version also includes the program’s name in such messages so that the source of any future messages will be more obvious.

share|improve this answer
    
I just updated to Mt. Lion and reinstalled tmux and tmux-pasteboard (1.1) from macports, but I still get this message. –  kenny Sep 30 '12 at 22:19
1  
@kenny: What does your default-command look like (or however you are invoking the wrapper, if it is not through default-command)? Perhaps you are running some other build (e.g. an old, self-built version in your home directory instead of the one that MacPorts built and installed as /opt/local/bin/reattach-to-user-namespace)? The most recent package in MacPorts (port installed tmux-pasteboard shows tmux-pasteboard @1.1_0 (active)) does not issue the message on Mountain Lion (I just installed it after a fresh port selfupdate to verify). –  Chris Johnsen Oct 1 '12 at 3:07
    
Yes, that was the problem. I had an old self-built version in ~/bin. –  kenny Oct 1 '12 at 20:53
add comment

Nope, but try the new version (you can find it into the iTerm2 beta download package)

share|improve this answer
    
Can you add the download link? Your post would become even more useful. Thanks! –  myhd Sep 26 '12 at 21:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.