Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Yesterday, I installed World of Warcraft on my MacBook Pro (13", 2009) and it crashed, so I forced a restart by holding down the power key. The boot failed, and here's what happened: The Apple logo appeared with the spinning circle below it and a grey progress bar. But about 10% into the progress bar, it stopped and the computer shut down. I tried rebooting about 10 times, with no luck and the same behaviour. I then tried reinstalling the OS using the Recovery tools, but that failed, too. After inputting my Apple ID credentials, an error message appeared, asking me to try again later. It failed every time I tried.

Eventually, I erased my partition using Disk Utility in the Recovery tools, and I was able to reinstall the OS from the Internet.

But this same problem happened to me on Lion, too, so I was wondering what causes it, because I'm almost certain it will happen again. I think it has something to do with the third-party SSD I installed (a Kingston SSDNow), but other than install it, I haven't messed with the system in any way (I haven't enabled TRIM support). Also, I had FileVault enabled.

I apologize if this was long, I was trying to provide enough background/details. My question would be, what caused the error and how can I avoid it in the future?

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.