Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I recently did a clean install of Mountain Lion (upgrading from Lion). Exported my calendars to a "Calendar Archive" on Lion and then imported them on Mountain Lion.

Maybe I broke something, but I don't see a way to add new calendars "on my mac". The only option i have in File | New Calendar is "iCloud" (which is not what i want). Is there a preference I'm missing somewhere?

A possibly related problem: syncing with iCloud seems to be broken. I get a triangle alert icon to show there has been a problem (but there is no clue what the problem is). I spent and hour on Google hunting but couldn't find a place to look for logged error messages.

share|improve this question
add comment

1 Answer 1

up vote 4 down vote accepted

Apparently you'll have to:

  1. Disable iCloud by going to Calendar > Preferences > Accounts. It seems important just to disable iCloud from Calendar's preferences, not completely sign out of it from within System Preferences.
  2. Create a new calendar which name does not conflicts with any calendars you've already got in your iCloud.
  3. Enable your iCloud account.

This will make the new calendar, under On My Mac to remain.

share|improve this answer
    
Brilliant. Thank you. Worked perfectly. –  Steve Aug 30 '12 at 23:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.