Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have performed an upgrade to the latest Snow Leopard and now to Mountain Lion (10.8.1). Post upgrade my desktop background isn't no longer changing. The background will not change when I try and select a different background via system preferences. Even if I reset it to the default background the same behavior persists. My system has exhibited this problem for almost 7 months now, I have this ugly plain blue background I cannot look at any more. Can anyone offer a solution that might resolve this?

share|improve this question
This won't fix the problem, but try this to see if it works. Save a picture to your desktop and then either two-finger tap it or right-click it (whichever fits your input mechanism) and select "Set Desktop Picture" to see if that will at least give you a new image to look at. – Zrb0529 Aug 27 '12 at 23:18
Also try to use Repair disk permissions on your boot hard drive using Disk Utility. – Ricardo Sánchez-Sáez Aug 16 '13 at 14:54

Try deleting /Users/username/Library/Preferences/

Then, empty your trash and reboot. This file stores the preferences for desktop wallpaper and deleting it will give you a clean slate. Your system should default to the standard Mountain Lion wallpaper.

share|improve this answer

Open Terminal (Applications/Utilities/ and paste this command

rm ~/Library/Preferences/

press 'return' on the keyboard.

Log out, log back in again. Change the wallpaper to what you want. Log out, log back in once more to test.

Any improvement?

share|improve this answer
This may well solve the issue the poster is having - but can you write a bit about the solution you suggest? – Scot Aug 16 '13 at 16:22

My steps (on El Capitan 10.11.2):

  • Deleted problem persisted
  • Replaced /System/Library/CoreServices/DefaultDesktop.jpg (req. disabling System Integrity Protection here) - problem persisted
  • Repaired permission for /System/Library/CoreServices/DefaultDesktop.jpg as detailed here - problem SOLVED (can choose new desktop image via Sys Pref. as normal)
share|improve this answer

Note that you have to delete the file as another user. Otherwise, the original settings will be restored from cache.

share|improve this answer

By any chance have you performed a repair permissions using disk utility lately? Perhaps there is a problem with the OS accessing the files it needs.

share|improve this answer

The easiest fix for this is to just go into your desktop and screen saver settings, under the system preferences tab, and click on the "change picture" button. Then it should allow you to set the background to what you want again.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.