Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've got an issue with my iMac...

Let me explain the configuration:

  1. The router is connected to the internet, the WiFi is turned off.
  2. Time Capsule is connected to the router with an ethernet cable, it's in Bridge Mode, the WiFi is set to 802.11 n only, the 5GHz is set to channel 36 and the 2.4GHz is set to channel 8.
  3. Airport Express is connected to the network created from Time Capsule, it extends the network in 2.4GHz (this AirPort Express doesn't support dual bands).
  4. Apple TV is connected to the network in 5GHz.
  5. iPad 2 is connected to the network in 2.4GHz.
  6. iMac is connected to the network in 5GHz.
  7. iPhone 4S is connected to the network in 2.4GHz.
  8. MacBook Pro is connected to the network in 2.4GHz.
  9. The printer is connected to the network in 2.4GHz.

The trouble is:

  • When the iMac is in sleep mode, after a few hours it dissapear from the network. So I cannot access it while on the go with my iPhone through 3G network, neither from my Macbook Pro on the same network.

Well, I hope everything is clear to understand...

Thanks in advance

share|improve this question
    
How old is the iMac? Reliable wireless Wake-On-Lan may require newer hardware than you have. –  Thorbjørn Ravn Andersen Aug 25 '12 at 9:47
    
I checked everything, still the same... My MacBook Pro doesn't have this issue with the same settings while my iMac does. –  user36666 Dec 14 '12 at 21:38

3 Answers 3

I found someone else with this specific problem. My understanding is that Apple's Airport Base Stations simply "forget" the previously attached computer.

Two things to check:

  1. Create a static IP address in network configuration on the iMac
  2. in Airport Utility make sure you've created a MAC address based DHCP reservation for this iMac. Apparently, the AEX AEB & TC will still "forget" but it might be longer now, like 6-8 hours.

The work around: using either and application or System Preferences > Energy Save schedule the iMac to "wake up" and turn back off every 6 hours or so if not being used. This should re-up the IP. Alternatively, DD-WRT router software supports WOL out of the box. Wireless WOL is not part of the spec, however, I believe wireless WOL is an Apple deal.

share|improve this answer

Firstly, make use that "Wake for network access" is checked in the Energy Saver preference pane of the System Preferences.

If this fixes your problem, then stop here, otherwise continue...

If your iMac is quite new, then it will have the Wireless Wake-On-Lan feature, but it doesn't seem to work correctly. Contact Apple. A reinstall of your operating system may fix this problem.

If your iMac is a older model, then Wireless Wake-On-Lan will not be available to you. You must alter your set-up so that your iMac connects using ethernet, to take advantage of traditional Wake-On-Lan.

Either:

  • Connect the Time Capsule to the iMac directly using an ethernet cable.
  • Move your current Airport Express (or buy another one), and place it close to your iMac, connect the iMac to the Airport Express using an ethernet cable, and set the Airport Express to extend the network (bridging mode).
share|improve this answer
    
A reinstall of Mac OS X is rarely needed. –  lhf Nov 2 '12 at 0:29

Is the basic problem that you can't wake your iMac from a device outside your LAN (you say you want to wake a LAN device over 3G and don't mention VPN, so the 3G device must be on the WAN)?

If that is indeed the issue, then I would put the modem-router in bridge mode, and have the Time Capsule do NAT instead.

Apple designs their devices to be easy to configure with the services they advertise (like sleep proxy, icloud, etc) but it's harder for them when you have a generic device making decisions about incoming traffic.

So again: have the modem-router just pass everything wholesale to the Time Capsule, so that it can handle NAT.

share|improve this answer

protected by Community Dec 14 '12 at 22:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.