Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

So here's the thing. The rMBP is on Mountain Lion with all possible updates. When I open the lid I can see the login screen just fine but it is unresponsive for several seconds, can't enter my password or move the cursor. Sometimes it makes the 'pop' system sound like it's getting a new mail or something several times in immediate succession, like pop-pop-pop-pop, just after opening the lid. Now this might make you think it might be related to power nap but this is happening before power nap came along. If I remember correctly, this happened before I installed Mt. Lion too.

Another very clear symptom is whenever I log back in from sleep and had the problem just described, the RAM in activity monitor is always clear. All green.

It is almost faster to cold boot it. Any ideas?

share|improve this question
    
You should limit each question to one subject. It's fine to post multiple questions if you have different problems though. If you could edit out one of the two questions and create a seperate thread for that? –  Gerry Aug 23 '12 at 9:12
    
The delay before the sound output device is changed is probably normal. Can you include the output from the All Messages section in Console after waking up from sleep? What does pmset -g return? Does the delay go away if you change the safe sleep mode? –  ؘؘؘؘ Aug 23 '12 at 20:12
    
Another thing you could try would be to disable launchd services installed by third party applications by moving the property lists in the LaunchAgents and LaunchDaemons folders in the user and root libraries somewhere else and restarting once before going to sleep. See MacBook Pro: long time to wake from sleep, what could it be?. –  ؘؘؘؘ Aug 23 '12 at 20:19
    
Hi, I'd keep that in mind next time Gerry. And I'll edit out this post, just thought they might be related so this could be relevant info. @ Lri, thanks for your suggestions. I actually did change the hibernate mode to 0 and that solved it. I'll post an answer describing it. –  Ankit Aug 24 '12 at 5:54

3 Answers 3

I actually experienced this on my '12 MacBook air as well and it was driving me crazy so I think I've figured it out without having to buy any apps like smartsleep, etc.

So first off you need to look at how the Mac operates with its settings. The pmset command from Terminal shows and controls the settings. Don't change anything until you read the man page. Enter pmset -g in Terminal to see your current settings.

pmset -g | grep hibernate mode
hibernatemode     3
pmset -g | grep standby
standbydelay      4200
standby             1

Those are the defaults and you should read the full details on Apple's Man Page.

But basically what that means is after 4200s (70min) of regular sleep ("standby" on Windows), it goes into deep sleep ("hibernate" on Windows). From testing, wake from deep sleep takes about 3-4 seconds or up to 10 seconds depending on what you had open (all SSD times of course).

Now you can increase this time which means it remains in standby (aka memory is still powered). I have mine set to 42000s (700min) so that it covers most of my inactive scenarios (sleep, travel etc) and only hibernates on an errant weekend or two where I don't turn my computer on. Mac OS still creates the hibernate file anyways so you don't risk losing data. I have yet to test its affect on battery drain but maybe someone here can do that.

To set the standbydelay to 42000 seconds (11.66 hours), in your Terminal, type:

sudo pmset -a standbydelay 42000

and enter your password.

Now if you'd rather have it based on battery percentage there's a neat loophole. You see Power Nap basically also means that you have to keep standby active as obviously waking from Hibernate is inefficient. So when you check Power Nap on battery you are essentially keeping the computer on Standby until you hit 30% and then it will hibernate. This is because Apple set up Power Nap to do this so you can use this mechanism as well.

I've tried both and now my computer wakes quickly all the time.

share|improve this answer
    
isn't that the OSX power profile, how does it affect Windows? –  Ion Todirel May 14 '13 at 15:35
up vote 2 down vote accepted

Okay, I found a helpful link somewhere on Macrumors or here on Ask Different, can't really remember. Basically this is due to an added hibernate mode for new MacBooks to enable the '30 days standby time' that apple promises.

These machines go into a deep sleep or hibernate mode after about an hour of sleeping which writes your RAM contents to your SSD and switches off your RAM and other things so even more power is saved. So when you wake your computer up from this deep sleep, it takes about 5 seconds for the machine to read the previous RAM contents from the SSD.

This isn't the best solution according to me since I'd be waking up my machine far more times after an hour but would probably never need it to sleep for 30 days (or even 3 days :P). IMO this should be done as a precautionary measure only, when the battery is low and the computer will self shut down. This article, from Macworld explains in a bit more detail and also tells you how to change this behaviour. http://www.macworld.com/article/1053471/sleepmode.html

I've also found an app that I'm going to buy for this purpose, it's called Smartsleep. This one gives me the flexibility that I need. It will let me specify a specific level of battery at which hibernation will automatically kick in. Levels above that and the computer will just sleep, and wake in less than a second every time.

share|improve this answer
    
I'd just like to add that I'm using normal 'just sleep' mode since yesterday and everything works normally.Today when I woke the machine up after 10 hours or so, it was up before the lid was fully opened, just the way I like it. :) Also, this does not affect the 'Reopen windows when restarting' option. –  Ankit Aug 24 '12 at 6:13

I also was confused about this and found help about the topic.

Basically disable sleep by

sudo pmset -a standby 0 ~stops sleepsmode/hibernation

or Delay it using

sudo pmset -a standbydelay 7200 ~delays it to 7200 seconds or 2 hours

Check this for more info Disable Stand By Mode on Retina MacBook Pro?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.