Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm trying to configure a lab of OS X workstations to print to a Ricoh Aficio MP C5000. The Aficio is configured to require user authentication (a 4-digit passcode) in order to print.

In Mac OS X System Preferences, I've created a printer (LPD connection to the Aficio's IP address). When I print to it, OS X thinks the print job has completed successfully.

The job shows up on the Aficio, but immediately has status "Cancelled", with the error log message "You do not have a privilege to use this function. This job has been cancelled".

How can I tell OS X to authenticate before sending the print job? (I don't see any field for entering the passcode in the OS X printer settings.)

I've already tried:

  • Setting the "User ID" under "Job Log" in the Mac print dialog.
  • Setting the "User Code" under "Job Log" in the Mac print dialog.
  • Setting it up as a Windows printer but OS X is unable to connect to the Aficio using this protocol.
  • Using the Gutenprint driver but that makes no difference.
  • Using IPP instead of LPD, but that makes no difference.
  • All of the above on both Lion and Mountain Lion; neither works.
share|improve this question
    
Does the pin need to be entered on the printer itself? If so there's surely no way around that. –  hellothere Aug 22 '12 at 23:44
    
No — the Windows driver has a field into which you can enter the pin, and print remotely without having to touch the device. I just haven't been able to find a similar setting with the OS X driver. –  smokris Aug 22 '12 at 23:47
    
Does this help... It has something about a Job Log listed as a required step... m.wpi.edu/academics/CCC/Help/Software/Macintosh/ricoh.html –  hellothere Aug 22 '12 at 23:55
    
OH! Wow. I didn't expect it would be under a menu item called "Job Log". That might be it. I'll give it a try when I'm back on-site tomorrow. –  smokris Aug 23 '12 at 0:01
    
Let me know how it goes :) –  hellothere Aug 23 '12 at 0:02
show 2 more comments

3 Answers

User codes are setup via either WIM (using the machines IP address in a browser on same network) or on the device itself it is called User code Authentication.

Now you can assign a prompt for a suer code on all services (Aside from printing as this is handled by pacing the code into the 'Valid access' tab on the driver.

On newer models you can edit the driver to force a prompt on the driver to access the user code.

To enable user code auth. see the following:

User Tools/123 key --> System Settings --> Administrator Tools --> Next --> User Code Authentication.

Select User Code Auth.

Select the options in which you require a user code to authenticate.

Press Ok.

Now you need to add a user code, select the previous key.

Address book management --> New Program --> Add a name --> Select the Auth info. tab --> Apply a user code.

share|improve this answer
add comment

I have the same problem. From what it looks like, it seems a problem in the driver. When I print from Windows, the username/password is passed correctly to the printer. When I print from OSX the username is blank when I look at the printer logs.

It's not clear OS X drivers allow stored passwords or will prompt for them.

share|improve this answer
add comment

Put in user code under job log and save the setup as a profile. User code remains embedded in that profile

share|improve this answer
    
I already tried that (see the "I've already tried" section in my question) — the Ricoh still cancels the print job without printing it. –  smokris Nov 19 '12 at 16:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.