Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a new Mac Book Pro (MBP) retina connected via HDMI to a Dell U3011 display. Every few seconds, but irregularly, the display pops up "MESSAGE Unsupported audio format. Please set the audio output on your audio player to Pulse-code Modulation (PCM) if available"

The message is dead center on the screen and lasts much too long. This is highly disruptive and makes it almost not worth it to use the screen.

I would like to find any way at all to turn off the message, either on the Mac side, the Dell side, or both. I do not need to pipe audio from the Mac to the Dell or vice versa. I'd be happy with a way to turn off ALL messages if it will get rid of this one.

Here is what I have tried. In the Mac's System Settings, I found Sound, the Dell shows up as one of the audio devices, but all settings are grayed out on it.

I have muted the sound on the mac via the function key F10.

I've been to the Apple support forums and not found a solution. I also left a message there.

I've been through the Dell manuals online for the U3011 and not found any way to configure the HDMI in port to turn off audio, and not found any way to turn off the messages.

I've been through all the on-board menus of the Dell, including the sound menu. The only option in that menu seems to be 2.0 versus 5.1. I didn't see a way to turn off sound input, and I didn't see a way to turn off messages.

It could be I've just missed the appropriate documentation or menu item, but I spent considerable time looking without success and thought I'd consult the sages at "AskDifferent."

EDIT: I'm pretty sure the message comes from the Dell firmware and not from the mac because it looks just like all the other messages from the Dell: it's in a non-Mac font, it's at a different resolution, there's no anti-aliasing of the font, etc.

share|improve this question
1  
Have you tried plugging in headphones into the mac to direct the sound through there instead? Might be a workaround? –  hellothere Aug 22 '12 at 23:50
    
I'll give this a try tomorrow morning when I'm back in front of the Dell. Good idea! –  Reb.Cabin Aug 22 '12 at 23:59
    
Let me know how it goes :) –  hellothere Aug 23 '12 at 0:00
    
sadly, it did not work :( The screen is still popping up this disruptive message even with headphones plugged in and configured in System Preferences to be THE output device :( –  Reb.Cabin Aug 23 '12 at 16:50

1 Answer 1

up vote 0 down vote accepted

Verified that this device http://www.monoprice.com/products/product.asp?c_id=104&cp_id=10428&cs_id=1042802&p_id=8119&seq=1&format=2 fixes the problem EDIT: using displayPort between the adapter and the screen)!

share|improve this answer
    
This doesn't solve the problem for me. I want to keep using the HDMI output on my macbook. I have two other displays running from the thunderbolt ports. –  wuliwong Sep 6 '12 at 20:14

protected by Community Nov 19 '12 at 16:02

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.