Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an office environment with 2 iMac's. We are using an Windows 2008 R2 server in workgroup mode for simple file sharing, DNS requests, and to run an application that requires Windows. I am trying to use Apple Remote Desktop 3.6 (470.93) from iMac1 to connect to second (iMac2).

When I enter an IP address for the second iMac and leave the DNS Name blank it will save the connection but upon trying to connect via the "control" option ARD fails to find the target system. If I enter just the DNS name (as indicated on target iMac under sharing and not the IP address, ARD save the connection with the DNS but without the IP address and it fails. iMac1 is running OS X 10.7.4 and iMac2 is running OS X 10.6.8 and ARD 3.5.3.:

enter image description here

enter image description here

  • I have verified that both machines have REMOTE Management enabled under sharing in preferences.
  • We have both forward and reverse lookup zones on the server and I have verified that they are working properly.
  • I have determined that our hardware firewall is not an issue as well.
  • Both machines are on LAN and I can ping either machine from Windows server
  • Both iMac's are physically cabled via ethernet
  • Both machines are on same subnets
  • Ethernet switch has been power cycled
  • Both iMac's have been rebooted

iMac1 was as some point in the past able to connect to iMac2 with no issues according to internal users with this configuration. Looking for suggestions for possible place to continue to trouble shoot. I can also provide additional information as requested.

share|improve this question
up vote 1 down vote accepted

Try using the "kickstart" command on iMac2:

sudo /System/Library/CoreServices/RemoteManagement/ -configure -users USERNAME -access -on -privs -all -clientopts -setmenuextra -menuextra yes -restart -agent -menu -console

(Obviously change USERNAME to whatever local account you wish to use to control via ARD).

Remote Desktop is still a really finicky, crashy beast (even on 3.6).

share|improve this answer

I got the same error message on a small number of machines that I look after, I was able to SSH onto a machine but not control it via ARD - indicating that the sharing preferences were correctly configured but something else was "broken". I tried the "kickstart" above, sadly with no positive result. My Kit included: Late 2011 MBP, 10.8.2 OS with ARD 3.6.1 Admin and a mix of client versions (3.6 and 3.6.1) Their OS versions being a mix of 10.7.x and 10.8.2.

Here is how I managed to fix it in the end:

  • On the client machine that you cannot connect to (obviously you will need to physically be in front of the machine - or if you're good with the CLI and can SSH to the box you could do it that way - these instructions stick with the GUI). Log in as an admin user and locate the /Library/Preferences/ folder, then remove:

  • Then open System Preferences and uncheck both Remote Login and Remote Management

  • Next recheck both Remote Login and Remote Management
  • Make sure to add the allowed users again and all desired control options.
    • Note: this will recreate the plists you've just deleted, only now they should work.
  • Now try and reconnect to the client machine via ARD.
share|improve this answer
Note: I have only had this issue with clients running on 10.7 or above. I have tried to connect from both 10.6 (ARD v3.5.3) and 10.8 (ARD v3.6.1) Admin machines - Something "screwy" with the 10.7 and above updates :-) – Olly Dec 19 '12 at 12:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.