Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've updated to Mountain Lion, and I'm having some DNS problems. I always PPTP/L2TP VPN connections on my macbook. Recently after a while of working with Mountain Lion, VPN stops sending and receiving data and I have to disconnect/connect again to make it work again. I'm not having the same problem with iPad, iPhone and PC.

and without the VPN, when I try pinging , and other DNSs and all I get is timeouts! But the ping works fine on my other devices. I also tried setting the DNS to Google and OpenDNS DNSs (,,, ...) but it still didn't help. I also tried emptying DNS cache and other solutions. but nothing.

I'm guessing that these two problems are tied together. Any solutions?


share|improve this question

change the primary DNS to your local gateway address, like or I have the same problem in PC, try it, It may be useful ;)

share|improve this answer
In Mac OS it is set to local gateway by default if you don't provide any other DNS. So that's not the case – Sallar Kaboli Aug 21 '12 at 18:26

in windows too but set it manually, and use the "" in secondary DNS server... if u have this Problem without VPN, use one of these DNSs : or use the "namebench" software to find best local DNS server for u... ;)

share|improve this answer – S a j a D Aug 21 '12 at 18:33
up vote 0 down vote accepted

Updating to OS X 10.8.1 fixed the bug.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.