Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Mac OS X Spaces change when I hold the mouse at the edge of the screen. Is there an application or 'defaults' command to disable this?

Warp looks like it might help, but hasn't changed the behavior for me, even though I tried turning it off, or setting a modifier key.

share|improve this question

migrated from superuser.com Jan 9 '11 at 5:53

This question came from our site for computer enthusiasts and power users.

    
The answers given are interesting, but do not explain why the mouse would switch workspaces when you are not dragging a window. I added a different answer that I think answers this question. –  Omnifarious Feb 27 '12 at 21:04

4 Answers 4

up vote 15 down vote accepted

I found a solution. The following sets the delay to 1 minute.

defaults write com.apple.dock workspaces-edge-delay -float 60 && killall Dock

source: Leopard: Lower the window drag delay between spaces

share|improve this answer

OS X - Snow Leopard seems to have two states when it comes to the switching behavior. Dragging a window or not dragging a window. If you are not dragging a window, it ignores your mouse hovering at a side. This makes sense, or the dock and hot corners would be very hard to use. When you are dragging a window, it auto-switches workspaces if you hang around at a side. This also makes sense.

Sometimes though, it seems to get confused about if you're dragging a window or not. When this happens, even if you aren't dragging a window, it still flips workspaces if you hover the mouse on a side, thereby making the dock and hot corners very hard to use.

In order to reset this state, I figured out that you can pick up a window, drag it around a bit, then let go. This seems to reset its "you're currently dragging a window" state with respect to workspace switching.

share|improve this answer
    
I don't think switching with mouse without dragging is a bug. It is another method to switch from one space to another, which is often done without moving an app. –  user588 Feb 28 '12 at 22:26
    
@mankoff - Then why does it switch when I stay in a hot corner or try to access the dock? That doesn't seem like correct behavior to me. –  Omnifarious Feb 29 '12 at 6:43
    
Don't know why, but this works and seems to address this bug (yes, it's most definitely a BUG!). –  Scott Biggs Mar 29 at 12:10

It only switches when you're actively dragging something and linger on the edge of the screen for several seconds. Simply hovering shouldn't change anything.

share|improve this answer
    
Agreed. mankoff, can you detail what is done a bit more before Spaces changes? –  vgm64 Mar 21 '10 at 4:52
    
mine seems to switch after about 1 second, which is too quickly. I never want it to switch this way at all. If I could set it to 10 seconds that would probably be OK. I think the problem occurs like this: I drag something to the top (or side) and then spend 1 or 2 seconds fine-tune positioning it to the left/right (if at top) or up/down (if on side). During this fine-tune positioning, I keep it against the top (or side) and the switch occurs. I just want this behavior to go away. –  user588 Mar 21 '10 at 4:57
    
Sorry for the poorly worded original question. Hover was the wrong word. I've edited it. –  user588 Mar 21 '10 at 5:17

I am using Warp successfully to do that. I've checked "Enable Warp" and "Click screen edge to Warp". When I touch an edge, I get a small window surrounding the cursor that either shows a tiny view of the adjacent space and its windows, or says "No windows" -- is that what you're seeing? At that point, clicking will change spaces, or you can back away from the edge to remain in the same space.

Edit: Oops - I have to backtrack. My answer applies to just the mouse cursor, not to dragging a window. I see the same behavior you describe if I drag a window to the edge and hover there holding it: Spaces will switch repeatedly until I back the cursor off of the edge.

share|improve this answer
    
Actually for some reason warp has no effect on my computer. I've logged out and back in but not rebooted, but I don't see why it would need a reboot. I cannot get the behavior you have. The time slider doesn't have an effect (it is always about a second). Modifier keys don't do anything. Etc. Which is fine, I think, because I don't actually want to warp... –  user588 Mar 21 '10 at 5:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.