Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Lion, TextEdit used to open with a blank file by default. On Mountain Lion, it launches with a file picker by default — either for choosing to store the file in iCloud or for opening a local file.

How can I make TextEdit launch with a blank file by default in Mountain Lion?

share|improve this question
    
Man this was bugging me. Glad you asked this question. – ClearCloud8 Aug 22 '14 at 22:50
up vote 42 down vote accepted

If you don't want to disable syncing documents and data, run

defaults write -g NSShowAppCentricOpenPanelInsteadOfUntitledFile -bool false

and quit and reopen TextEdit to apply the changes.

share|improve this answer
2  
This is the right answer. – Danyal Aytekin Jan 3 '14 at 10:46
    
And, to reverse this if necessary, I think the necessary incantation is defaults delete -g NSShowAppCentricOpenPanelInsteadOfUntitledFile – Ashley Jan 28 '14 at 0:23
    
Awesome answer. I salute you. – Vinozio Oct 30 '14 at 16:13
    
Also works on Yosemite 10.10. – Nick Woodhams Nov 4 '14 at 10:17
    
On OS X El Capitan, I had to also follow these steps: Open Text Edit, Create New Document, Exit, Completely Quit TextEdit. After that, a new blank page came by default (at least for now) – user3684424 Dec 18 '15 at 20:21

Go to System Preferences > iCloud > uncheck "Documents & Data" from the sync list.

share|improve this answer
1  
Doing this will remove the possibility to save and sync documents and data from any application in OS X. – Hoshts Aug 20 '12 at 21:26
    
It's the only way - otherwise, it'll prompt whether you want to save a document to iCloud or locally. Remove iCloud from the mix, you get a blank document locally. – hiiambo Aug 20 '12 at 21:26
1  
Thanks, that was annnnoooyyying as hell! – Leon Gaban Jun 24 '13 at 14:27

System Prefrences > iCloud > iCloud Drive ( Options ) > uncheck textEdit

share|improve this answer

protected by Community Mar 18 at 12:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.