Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top


OS X 10.8
TextMate 2 -r9283


How can I permanently force TextMate to to always default to soft tabs (use spaces, not tabs)?

I want to know how to make TextMate default to this setting so that I don't have to constantly convert tabs to spaces while working on a file.

How do you permanently tell TextMate 2 to prefer soft tabs?

share|improve this question
up vote 8 down vote accepted

TextMate 2 uses a special file called .tm_properties to control lots of settings in the app. It will use ~/.tm_properties if present for global defaults. You can also add one inside a source tree to control settings for a particular project.

The setting you're looking for is:

softTabs = true

Just add that line to ~/.tm_properties (or create it if it doesn't exist).

You can read more about this file here.

share|improve this answer

Put the following in ~/.tm_properties:

softWrap = true
tabSize = 4
softTabs = true
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.