Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm currently dual booting Mountain Lion and Ubuntu 12.04 on a rMBP. Everything works fine, but enabling FileVault fails with the error message: "Some information was unavailable during an internal lookup." I receive the same error message if I run "Verify Disk" in Disk Utility.

By experimenting over the course of half a dozen reinstallations, I made the following observations:

  1. Install Ubuntu 12.04 (x64, alternative Mac version) and GRUB -> ERROR
  2. Add a ext4 or btrfs partition using Gparted on a LiveCD without installing GRUB -> ERROR
  3. Removing the Linux partitions (but leaving the hybrid MBR) -> NO ERROR

As a result, my best guess is that OS X throws an error as soon as it detects a filesystem that it doesn't recognize. Has anyone else encountered this problem? How do get OS X to ignore my Linux partitions?

Update 1

Adding 128 MiB of padding between partitions solves the "Verify Disk" error. Unfortunately, I still get the same error message when I attempt to enable FileVault 2. Interestingly, "Verify Disk" started returning errors as soon as I attempted to "Repair Disk." Disk Utility seems quite adept at corrupting its own partition tables...

Update 2

I get more information if I run fsck_cs from the terminal. It looks like this may be related to FireVault2 using CoreStorage. Here's the output:

$ sudo fsck_cs /dev/disk0
** Checking volume.
   Content Hint for disk0 is not Apple_CoreStorage
** disk0: Scan for Volume Headers
   Invalid Volume Header @ 0: invalid field value
   Invalid Volume Header @ 251000192512: invalid field value
** disk0 is not a CoreStorage volume
share|improve this question
add comment

1 Answer

I believe I found the issue: Apple expects 128 MiB of free space between every partition. Disk Utility hides this free space, similar to how it hides the ESP. If this padding isn't present, it generates the error I described above.

Easy fix: Tell Gparted to use +128 MiB as the beginning offset for each partition.

Edit: Nevermind, this only solves the "Verify Disk" problem...I still can't enable FileVault. See above for an update.

share|improve this answer
    
Interesting! Is your partition map GUID? –  hellothere Aug 19 '12 at 7:08
    
Yes, it's GPT with a hybrid MBR. I'm working on EFI booting Ubuntu to ditch the hybrid MBR, but I haven't gotten it quite working yet. –  Michael Koval Aug 19 '12 at 7:26
    
Nevermind. This only solves some of the problems. See above for an update. –  Michael Koval Aug 19 '12 at 16:44
    
FileVault won't work on an MBR partition map –  hellothere Aug 19 '12 at 17:35
    
I'm using a GPT partition map and have the same problem even if I manually restore the protective MBR. Is there any way that the MBR could still be the problem? –  Michael Koval Aug 19 '12 at 18:39
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.