Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I love Byword.app and there's a very handy quick key (⇧-⌥-p) that, recently, started showing the uppercase Greek character pi (∏) instead.

I'm not sure what I changed, but it's very frustrating, as I have never needed this character in the past, nor as easily.

I have looked through all the Keyboard and Language preferences, keyboard and character viewers and so on, searched online, and I can not find a way to disable this.

Please, help me get this key combination back!

Thanks!

UPDATE:

I realized I had the Byword key-combo wrong, it's actually ⌘-⌥-p! (doh!) However, I'd still like to use shift-option combos for other things so I'll leave the question up.

share|improve this question
    
Is it specific to Byword? Π is normally inserted by option-shift-P on some keyboard layouts, so what does option-shift-P do? –  Lri Aug 18 '12 at 19:30
    
Whoops, I mean option-shift-P! Thanks, will edit the above. –  SteveLambert Aug 19 '12 at 17:37
add comment

1 Answer 1

Is the ⌥⇧P shortcut a default in Byword? In OS X, shortcuts involving option without command or control as a modifier are for inserting special characters, like the symbol you're seeing inserted. I'm surprised that you're only seeing this functionality recently, as it's been there for many years - perhaps a recent Byword update changed something?

To my knowledge, there's no way of disabling these in System Preferences. You might be able to create a custom keyboard layout that would remove these, but I haven't tested that. I would suggest either setting a different shortcut for the functionality you want in System Prefs. The other (more awkward) way is to take advantage of the fact that the special character shortcuts only do anything in text entry fields. If you don't have a text entry field active, the shortcut should return to it's previous functionality.

share|improve this answer
    
Your question helped me realize I had the Byword combo wrong (embarrassing) so the immediate problem is solved, thanks! But I'd still like to use shift-option combos for other things, since I need shortcuts more than Greek characters. –  SteveLambert Aug 19 '12 at 20:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.