Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the current version Mountain Lion and set the Screensaver to 30 minutes, but since I am the only person that have access to this computer, I would like to turn the password off, but there seems to be no such method?

share|improve this question
Please, do you use FileVault 2? And what model is the Mac? – Graham Perrin Aug 18 '12 at 18:55
I don't use FileVault... (mine is FileVault, not FireVault 2 on the Mountain Lion)... it is a Mac mini, but does it matter? I thought Mountain Lion behaves the same no matter what Mac it is – 太極者無極而生 Aug 18 '12 at 21:22
The check box in the screenshot by @Hoshts is not seen on my computer running Mountain Lion with FileVault enabled. For security, it makes sense for Apple to limit/remove the preference. – Graham Perrin Aug 18 '12 at 22:10
I have FV2 enabled but still see this option in Preferences. Strange. – patrix Aug 27 '12 at 9:22
up vote 6 down vote accepted

Under System Preferences -> Security & Privacy there is an option to not require password to wake computer from sleep or screen saver.

enter image description here

share|improve this answer
For some users of Mountain Lion, that check box does not exist. – Graham Perrin Aug 18 '12 at 18:54
Depending on hardware I guess? – Hoshts Aug 18 '12 at 19:38
I'm not sure. Please see commentary to the opening question. At the time of your screenshot, did you use FileVault 2? – Graham Perrin Aug 18 '12 at 19:40
For anyone who still gets a password screen after unchecking this, it could be because the user you're logging in as isn't an Admin user. To make the user an Admin, go to System Preferences > Users & Groups > click the lock icon > select the user > check "Allow user to administer this computer" – Liron Yahdav Aug 10 '14 at 23:28

If you turn on FileVault then the checkbox disappears, so your only choice is how long it will take before you need to enter a password. I found this so irritating that I turned off FileVault altogether. Then the checkbox came back and I could get rid of that option.

What is also strange here is that when you have FileVault on (and thus have no choice about having to enter a password) the maximum time is 1 hour. When you have it turned off, not only can you turn the password option off altogether, you also have a maximum grace time of 4 hours.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.