Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I tried changing the Standby mode settings using the command sudo pmset -a standbydelay 5400 . I set it to 5400 so that it is delayed to 1.5 hours compared to 70 minutes as default.

However, I get the following message right after I changed it :

Warning: Idle sleep timings for "Battery Power" may not behave as expected. - Disk sleep should be non-zero whenever system sleep is non-zero.

What does this mean ?? Must I change the value back to 4200 ?

edit

Active Profiles:
Battery Power       -1*
AC Power        -1
Currently in use:
 standbydelay         5400
 standby              1
 halfdim              1
 hibernatefile        /var/vm/sleepimage
 darkwakes            0
 gpuswitch            2
 disksleep            0
 sleep                180
 hibernatemode        3
 ttyskeepawake        1
 displaysleep         5
 acwake               0
 lidwake              1
share|improve this question
    
Could you post the output of pmset -g? –  ephsmith Aug 17 '12 at 13:59
add comment

1 Answer

up vote 1 down vote accepted

Based on the output of pmset -g, you have your system set to sleep after 2 hours, but the disk sleep timer is set to zero--meaning never according to the pmset man page. To correct the error, set disksleep to a value greater than zero but less than (or equal to) sleep.

Use something like the following with your preferred disksleep time,

pmset -a disksleep 45

to set disksleep to 45 minutes for all power situations. You may want to adjust these times for when your MBPr is running on battery. Set battery profiles with -b instead of -a.

I think you'll benefit greatly from the pmset man page. It's very clear and You'll probably discover something else that pertains to your needs there.

share|improve this answer
    
Hmm Disk Sleep is related to the option Put hard disks to sleep when possible .. However I disabled that because I have SSD instead of HDD, so I do not really need that option (according to sources I read online) .. Does the warning message indicate that a severe problem might appear later on ? –  Render Aug 17 '12 at 14:50
    
I know what you mean. It doesn't appear to make sense, but apparently you can't have the system sleep without the disks sleeping ? –  ephsmith Aug 17 '12 at 15:00
    
This is just to work around your error based on what pmset expects. –  ephsmith Aug 17 '12 at 15:01
    
Hmm yeah, interesting. I read the pmset man page, thanks for the link. What would happen if I ignored the warning message ? –  Render Aug 17 '12 at 15:45
    
Since you have an SSD, I think it's safe to ignore. This option is infinitely more important for HDDs. –  ephsmith Aug 17 '12 at 20:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.